Closed Bug 1010311 Opened 7 years ago Closed 7 years ago

Storage services run by United Internet AG (GMX File Storage, 1&1 SmartDrive) don't work on Firefox 29

Categories

(Tech Evangelism Graveyard :: English Other, defect)

defect
Not set
normal

Tracking

(firefox29 affected)

RESOLVED FIXED
Tracking Status
firefox29 --- affected

People

(Reporter: kohei.yoshino, Unassigned)

References

()

Details

(Keywords: regression, site-compat)

It was first reported as an issue on Firefox Portable but the reporter confirmed it still happened on the vanilla Firefox 29.

https://support.mozilla.org/en-US/questions/998676
http://portableapps.com/node/41388
Created an account and tested... This time again, window.controllers is used to detect the browser. Ouch!

if (window.controllers&&typeof vBrowserProduct==="string"&&vBrowserProduct==="Gecko"&&/rv\:([^\);]+)(\)|;)/.test(vBrowserUserAgent)) {
  vEngine="gecko";
  vEngineVersion=RegExp.$1;
  if (vBrowserUserAgent.indexOf("Firefox")!=-1) {
    vBrowser="firefox";
  } else if (vBrowserUserAgent.indexOf("Camino")!=-1) {
    vBrowser="camino";
  } else if (vBrowserUserAgent.indexOf("Galeon")!=-1) {
    vBrowser="galeon";
  } else {
    vBrowser="other gecko";
  }
}
Blocks: 794943
Depends on: 1010577
Duplicate of this bug: 992652
Summary: GMX File Storage doesn't work on Firefox 29 → Storage services run by United Internet AG (GMX File Storage, 1&1 SmartDrive) don't work on Firefox 29
https://support.mozilla.org/en-US/questions/998676

> Gmx.com has just redesigned its webmail interface and surprise, 
> access to Gmx.com file storage now works OK now with Firefox 29 / 29.01. 

The guest URL in Bug 992652 also works well \o/
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.