DOMApplicationRegistry initialization dies on NS_ERROR_XPC_BAD_IID for nsISystemMessagesInternal

RESOLVED FIXED in Firefox 32

Status

()

defect
P1
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

({regression})

32 Branch
Firefox 32
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRuntime])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
DOMApplicationRegistry fails to complete initialization when an installed app has an activity to register, throwing:

 10353           GeckoConsole  E  [JavaScript Error: "A promise chain failed to handle a rejection.
 10353           GeckoConsole  E  Date: Wed May 14 2014 13:57:51 GMT-0700 (PDT)
 10353           GeckoConsole  E  Full Message: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]" {file: "resource://gre/modules/Webapps.jsm" line: 116 column: 0 source: "116"}]

This is the statement that throws:

  return Cc["@mozilla.org/system-message-internal;1"]
         .getService(Ci.nsISystemMessagesInternal);

It happens because Fennec doesn't package dom_messages.xpt.  Here's the fix.
Attachment #8422732 - Flags: review?(wjohnston)
Attachment #8422732 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/74f812525f7d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
You need to log in before you can comment on or make changes to this bug.