Closed Bug 1010603 Opened 5 years ago Closed 4 years ago

Cleanup ignored *.pyc in the source directory with a clobber

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1184696

People

(Reporter: MattN, Unassigned)

Details

It would be nice if a clobber would cleanup leftover *.pyc that may be leftover so it gets you back to a clean build environment. In bug 1008648, the build failed for users who had an source directory from 2011 as there were *.pyc files remaining in the source directory that were being used instead of the new version. Since *.pyc will be automatically recreated the next time the .py files are used, it seems pretty safe to me (though I'm no Python expert).

e.g.
hg st -i | grep "\.pyc$" | cut -f 2 -d " " | xargs rm
hg purge --all
I would like this change. Sure, you can manually delete the files with "purge" or just find/rm, but it's not always obvious that you need to, especially for developers inexperienced with Python in complex build systems. If we made this change then changes that are likely to cause .pyc-related breakage could clobber.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184696
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.