Closed Bug 1010642 Opened 6 years ago Closed 6 years ago

(vertical-homescreen) Implement new drop shadows for app icon labels

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P2)

x86
macOS
defect

Tracking

(feature-b2g:2.0, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
feature-b2g 2.0
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: pla, Assigned: kgrandon)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe],[p=2])

Attachments

(1 file)

All numbers are relative to Flame's 480x854 screen resolution.  Other screen resolutions should scale accordingly.

Every label gets two drop shadows:

1st drop shadow (thin/tight):
Angle: 120
Offset distance: 1 pixel
Size: 3 pixels
Color: #000000 @ 30% opacity

2nd drop shadow (wider):
Angle: 120
Offset distance: 5 pixels
Size: 10 pixels
Color: #000000 @ 40% opacity

Spec/screenshot to be attached.
I'm not sure if it's perfect, but this is the closest CSS definition I could come up for this: 

text-shadow: -0.1rem 0.1rem 0.3rem rgba(0, 0, 0, 0.3),
             -0.2rem 0.4rem 1rem rgba(0, 0, 0, 0.4);

Let's implement and see how it turns out.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe] → ux-tracking, visual design, visual-tracking, [ft:systemsfe],[p=2]
Target Milestone: --- → 2.0 S2 (23may)
feature-b2g: --- → 2.0
New shadows implemented: https://github.com/mozilla-b2g/gaia/commit/6fabfa9ff7427a41f62eb2c50d1c31092d122fe7

They're not exactly an angle of 120 degrees, but they're about as close as we can get them I think. Let me know what you think.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
FYI - I think the direction of these shadows might be wrong. This should be fixed when bug 1010640 lands.
Hi Kevin,

Here's a better spec.  I'll load your patch tomorrow to review.
Priority: -- → P2
Duplicate of this bug: 1020813
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
You need to log in before you can comment on or make changes to this bug.