Closed Bug 1010673 Opened 7 years ago Closed 7 years ago

[email] icon check for 2.0 redesign

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
2.0 S3 (6june)

People

(Reporter: jrburke, Assigned: jrburke)

References

Details

Attachments

(2 files, 1 obsolete file)

The icons.zip attachment contains all of the graphics I have integrated so far for the 2.0 redesign, and some are still the older style.

I think it would be easier if Fang were to update the icons in these folders with any that are missing, preserving the names where the new icon is just a replacement for the old one.

This list of icons came from the email 2.0 refresh branch (bug950208-email-2.0-visual-refresh), in this folder:

https://github.com/jrburke/gaia/tree/bug950208-email-2.0-visual-refresh/apps/email/style/images/icons

Some notes:

* The message list icon to enter edit mode seems to be a different shade of gray than the refresh icon. I believe the refresh icon is the correct one to use, I took it from the calendar 2.0 drawer.

* Similar shade of gray question around the icons used for actions while in edit mode in the message list, as well as the message-list-attachment icon shown for messages that have attachments in the message list.

* Some icons are actually different styles compared to the regular @1.5x and @2x sizes. edit-mode@1.5x.png vs edit-mode@2x.png is an example.

* I removed the @2.25x images that were in the repo -- not all icons had a 2.25x version anyway, so it seemed inconsistent. If they are needed, then please make sure all icons have one of that size.

* Not all have a "pressed" state either. If there are ones that should have a pressed state, then add them with a "_press" suffix (with a full range of @ sizes), and I can wire them into the UI.

If Fang can attach a zip with those updates, then I will take it and apply it to the 2.0 branch.
Attachment #8422909 - Flags: feedback?(fshih)
Comment on attachment 8422909 [details]
icons.zip, existing incomplete set

Hi James, 

Thanks for all the notes and this icon folder. 
I will check and fix all the icons, and update them asap! Thanks!
Attachment #8422909 - Flags: feedback?(fshih) → feedback+
Attached file Email_icons.zip (obsolete) —
Attached the updated email icons. Please let me know if there are any problems. Thanks!
Attached file Email_icons.zip
Attachment #8425251 - Attachment is obsolete: true
Duplicate of this bug: 1012896
Target Milestone: 2.0 S2 (23may) → 2.0 S3 (6june)
Fixed by commit mentioned in bug 950208 comment 23
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
[Environment]
Gaia      e98fe1e94d3d80ad36903500d8ca3333904b162c
Gecko     https://hg.mozilla.org/mozilla-central/rev/d6fccb7c56a8
BuildID   20140601160201
Version   32.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013

[Result]
PASS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.