Closed Bug 1010742 Opened 6 years ago Closed 6 years ago

Improve performance in dragdrop

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
feature-b2g 2.0
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Tasks to do:

1. Avoid some repaints
2. Just to render icons involved in the path between source and target icons
3. Add threshold to start drop animation
4. Clean a bit the code
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached video Video - Current state
Attached video Video with patch
Attached file Github pull request
Hi Kevin, this patch improves the performance of the dragdrop in the vertical homescreen. Please review carefully my patch because I am not familiar with this code as you are, so I could have added some regression or edge case thought. Don't be very hard with me hahaha. Thanks mate for your time
Attachment #8423047 - Flags: review?(kgrandon)
Comment on attachment 8423047 [details]
Github pull request

Hey - this is looking pretty good! There's still some problems with the bottom of the page and dragging icons over the last divider. Again, this is likely a result of the from/to handling. I think it's going to be tricky to get that part right, so I might recommend handling that as it's own patch. Perhaps we could just handle the delay/timeout part in this bug? That is looking pretty solid.
Attachment #8423047 - Flags: review?(kgrandon) → feedback+
feature-b2g: --- → 2.0
Also some of this may have been caught with better unit/integration testing. I'll try to do more of that in the next few weeks.
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S2 (23may)
Comment on attachment 8423047 [details]
Github pull request

thanks
Attachment #8423047 - Flags: review?(kgrandon)
Comment on attachment 8423047 [details]
Github pull request

Looks good, and I couldn't find any breakage. Thanks for the work on this!
Attachment #8423047 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/0b6cfe0b2ec0209fc3ae0ed24c60e35ce9bba28f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.