cannot select parts in java applet

VERIFIED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
VERIFIED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Matthias R., Assigned: Sergi)

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

When you browse through the parts tree and select e.g. the front view the whole
browser freezes.

Reproducible: Always
Steps to Reproduce:
1. goto to http://www.web2cad.co.uk/
2. select "CAD-parts"
3. select a part in the applet and double-click e.g. on "front view"


Actual Results:  Browser freezes!

Expected Results:  show the part list

I use Java Plug-In: Version 1.3.1_01

Comment 1

17 years ago
confirming on build 2001092103 on Win2k. Clicking on 'Front View' for the first
item (after opening the tree multiple times) freezes Mozilla. CPU usage is 0%
though.
Assignee: asa → edburns
Component: Browser-General → OJI
QA Contact: doronr → pmac
Summary: cannon select parts in java applet → cannot select parts in java applet
Marking NEW. Dupe of bug 95661?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

17 years ago
I don't think that it is a dupe of bug 95661 because that bug doesn't freeze my
mozilla.

Comment 4

17 years ago
Reassign to Joe as I'm leaving the role of OJI module owner.
Target Milestone: --- → mozilla0.9.5

Comment 5

17 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Reporter)

Comment 6

17 years ago
I just downloaded Mozilla 0.9.5
It's still freezing...

Comment 7

17 years ago
Matthias, would you explain more precisely what is "front view"
I did 3 of 4 steps you pointed and browser didn't hang.
I tested it on Solaris (build 095). Maybe this is Windows specific bug.
(Reporter)

Comment 8

17 years ago
@Sergey:
Here is an example.
Go to the java applet.
1. open the "AFAG (2D/3D) tree
2. open the "HM - Handling...." tree
3. open the "GM - Gripper..." tree
4. open the "GM12" tree
5. open the "GMQ 12/P..." tree
6. double click on "Front View"
7. freeeeeeeeeze!

Comment 9

17 years ago
Worked for on Linux and Win2k.

Comment 10

17 years ago
Solaris 2.8, build 0.9.4  - Borwser didn't hung but it seems to take forever for
applet to load. java console output to be attached

Comment 11

17 years ago
Created attachment 55123 [details]
Java Console output

Comment 12

17 years ago
I reproduce this bug on W2k (both 094 and trunk) using JRE 1.3.1_01 and 1.4.0 
betta2. 
As I see, the browser hangs only if applet brings up the dialog window "Please 
wait until evaluation page is loaded...". 
It looks like the awt lock occurs when dialog window disposes.

Comment 13

17 years ago
Re-assign to sep.
Assignee: joe.chou → sep
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 14

17 years ago
This bug still reproduces on current mozilla trunk (Mozilla/5.0 (Windows; U; 
Windows NT 5.0; en-US; rv:0.9.6+) Gecko/20011207) and newer version of the JRE 
(i use 1.3.1_01a)

However this bug is reproducible by using IE 5.0 and JRE 1.3.1_01a.
When I click on "Front view" item several times then both IE and Java Console 
hangs.

As I see, it shows that this bug is a JRE problem, not a problem of the browser.
But I do not yet able to figure out the exact reason of the hangs.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla1.0

Comment 15

16 years ago
I use 
Mozilla 1.1a+
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020716
and Java(TM) Plug-in: 1.3.1_03

to visit this site. it works well

Comment 16

16 years ago
wfm using build 2002072308 on Win2k (trunk) + JRE 1.4.1beta.

Updated

16 years ago
QA Contact: pmac → petersen

Comment 17

15 years ago
-- Verified it on latest trunk build on win2K with JRE1.4.2_Beta. Works fine.
Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
QA Contact: cpetersen0953 → dsirnapalli
Resolution: --- → WORKSFORME

Comment 18

15 years ago
-- Reporter if you still see the problem with latest JRE please reopen the bug.
Marking VERIFIED.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.