Closed Bug 1011072 Opened 7 years ago Closed 7 years ago

[B2G]Rotating to landscape while two app are open will shown both apps in landscape mode

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.0, b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED FIXED
2.0 S2 (23may)
feature-b2g 2.0
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: jschmitt, Assigned: etienne)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached file log.txt
Description:
While running two apps, rotating to landscape in one app e.g. Video will show both apps on screen.

Repro Steps:
1) Update a Open_C to BuildID: 20140515040207
2) Open the Video app
3) Proceed to the homescreen
4) Open the Email app
5) Switch back to the Video app
6) Rotate to landscape while in the Video app

Actual:
The second app is shown while in landscape.

Expected:
The second app is not shown while in landscape.

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140515040207
Gaia: 3a1d67246a79e3632c3b3f2460a25291e7e2714c
Gecko: e4843f4f08a7
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Keywords:
Edge Gestures, rotating

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
Attached image Landscape.png
Issue DOES repro on 2.0 Buri.
Issue does NOT repro 1.4 Open_C

1.4 Environmental Variables:
Device: Open_C 1.4 MOZ
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: P821A10v1.0.0B06_LOG_DL
The issue does NOT repro with Edge Gestures disable.
Etienne - Any ideas? Looks like this is a regression from edge gestures.
blocking-b2g: --- → 2.0?
Flags: needinfo?(etienne)
Whiteboard: [systemsfe]
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
Attachment #8423325 - Flags: review?(alive)
Going to remove regression keyword here since technically this can only happen if edge gestures are actually used.
Keywords: regression
Comment on attachment 8423325 [details] [review]
Gaia PR

This is another easy one that Vivien might be able to take :)
Attachment #8423325 - Flags: review?(alive) → review?(21)
Comment on attachment 8423325 [details] [review]
Gaia PR

R+ with a nit on the title. I let you guess where is the typo.
Attachment #8423325 - Flags: review?(21) → review+
https://github.com/mozilla-b2g/gaia/commit/e08ee056f8f32a5bed98229fa2d563b81ddac60a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0? → ---
feature-b2g: --- → 2.0
Target Milestone: --- → 2.0 S2 (23may)
You need to log in before you can comment on or make changes to this bug.