bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Basic mode search engine selection should be saved as user's default engine

VERIFIED DUPLICATE of bug 100078

Status

SeaMonkey
Sidebar
P2
normal
VERIFIED DUPLICATE of bug 100078
17 years ago
14 years ago

People

(Reporter: Tom, Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla 0.9.4 OS X Build 2001092016

If you use the search feature in the sidebar with a browser besides the default
dmoz.org, the drop-down menu will switch back to the default after re-starting
Mozilla. In previous versions (as recent as 2001091313) this drop-down list
behaved differently. It used to remember which search engine you selected, and I
think this is the way it should work. I mean, most people are habitual about the
search engine they use. 

Steps to reproduce:

1) Launch Mozilla.
2) Open sideabar, click search tab.
3) Use drop-down and pick Google.
4) Search for something.
5) Quit Mozilla.
6) Re-launch Mozilla.
7) Open sideabar, click search tab.
8) Drop-down has returned to default browser.

Comment 1

17 years ago
I can confirm that this bug happens on Windows 98, build 2001092208.  Since this
bug was reported against Mac OS X, the OS field should be changed to All.

This bug also occurs if I open a new browser window (file > new navigator
window) instead of relaunching Mozilla.
(Assignee)

Comment 2

17 years ago
This is not a regression.  This is a deficiency in the design.  We will address
this by making the selection in the dropdown become your default as has been
suggested by some involved in search UE.  Such a fix inthe implementation will
allow your selection be persisted across browser sessions.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Search engine selector drop-down on search tab returns to default dmoz.org search engine → Basic mode search engine selection should be saved as user's default engine
(Assignee)

Updated

17 years ago
OS: MacOS X → All
Priority: -- → P2
Hardware: Macintosh → All
Target Milestone: --- → mozilla0.9.6

Comment 3

17 years ago
search = claudius
QA Contact: sujay → claudius
(Reporter)

Comment 4

17 years ago
Re-confirmed in OS X 0.9.5 build 2001101516
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 100078 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.