Closed Bug 1011390 Opened 7 years ago Closed 6 years ago

HTML5 video fullscreen is downscaled by a few pixels if the video and the desktop resolution are the same

Categories

(Core :: Audio/Video: Playback, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nintendomaniac64, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

As far as I can tell this bug occurs in any and all existing versions of Firefox.

1. Set desktop resolution to 1280x720 without upscaling (1:1 pixel mapping)

2. Enable the YouTube HTML5 player via https://www.youtube.com/htmlp

3. Watch this video in fullscreen: https://www.youtube.com/watch?v=EG6wjMuP_Ig

4. Observe the per-pixel clarity, especially that of the on-screen text

5. Right click the video, select "Stats for nerds"


Actual results:

The text in the video was blurrier than if I played back the very same video in Chrome or in VLC, MPC-HC, etc.  Also the "Stats for nerds" says that the video dimensions were being displayed at 1278x719.


Expected results:

The text in the video should have pixel-perfect clarity; also "Stats for nerds" should show the video dimensions being displayed at 1280x720.
Attached image Chrome
How this situation looks in Chrome
Comment on attachment 8423683 [details]
Firefox 31 Aurora 2014-05-15

How the situation looks in Firefox 31 Aurora 2014-05-14
Attachment #8423683 - Attachment description: firefox.png → Firefox 31 Aurora 2014-05-15
Component: Untriaged → Video/Audio
Product: Firefox → Core
I would just like to point out that my use of 1280x720 was just an example, this applies to 1920x1080 as well (I just didn't have a good example video to show that).  Considering the popularity of 1920x1080 displays in HDTVs, monitors, and laptops, this issue will effect quite a few people come Firefox 31 with the enabling of DASH VP9 playback on YouTube.
Note that bug 729011 doesn't explain the two-pixel narrower width.
Depends on: 729011
Duplicate of this bug: 1055438
(In reply to Masatoshi Kimura [:emk] from comment #4)
> Note that bug 729011 doesn't explain the two-pixel narrower width.

On my 1920x1080 display Firefox 32.0.2 following 1920x1080 image is scaled  to 1918x1979
(right click -> view image info)

   http://spearsandmunsil.com/cms/wp-content/uploads/2013/02/1920x1080p24_Chroma_Zone_Plate_Main.png

So this problem applies not only to videos.

I'm using Fedora 20:
X.Org X Server 1.14.4
Release Date: 2013-10-31
X window information: it has 1920x1080 pixels:

]$ xwininfo 

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x4600092 "1920x1080p24_Chroma_Zone_Plate_Main.png (PNG Image, 1920 × 1080 pixels) - Scaled (99%) - Mozilla Firefox"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1920
  Height: 1080
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -0+0  -0-0  +0-0
  -geometry 1920x1080+0+0

$
Component: Audio/Video → Audio/Video: Playback
Xidorn - looks like a subtle fullscreen issue
I cannot reproduce this issue on Windows with DOM fullscreen on the current Aurora, either with image or with video. Youtube works perfectly for me as well. (See the attachment)
Note that the video fullscreen (which uses the Fullscreen API) is different with the fullscreen mode (which is triggered via F11 / Cmd-Shift-F).

Bug 729011 is about fullscreen mode, where we do take one pixel on the top to capture mouse event. We probably should also fix that, but that bug is unrelated to this.

Let me mark it as WORKSFORME. If anyone finds that it isn't really fixed, feel free to reopen this bug and provide your system info (which platform? what version?) and probably also testcase or steps to reproduce.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
No longer depends on: 729011
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.