Closed Bug 1011393 Opened 6 years ago Closed 5 years ago

Add support for 'csp' entries in Manifest Helper

Categories

(Core Graveyard :: DOM: Apps, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.1+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
mozilla35
blocking-b2g 2.1+
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: vlatko.markovic, Assigned: vlatko.markovic)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193838

Steps to reproduce:

Try to install web application that have 'csp' field in its manifest.


Actual results:

The 'csp' field is not copied to the application object during the application installation so later it is not accessible on runtime.


Expected results:

Copy the 'csp' field value from the manifest to the app object and install the application with it. If later asked to get the applications' CSP we should get what we had in the manifest.
Manifest Helper object is missing support for csp field in the application manifest. As consequence when using a Helper object to handle an application manifest it is not possible to access the csp string when needed. The results is that app objects for installed apps never gets the csp field if present in the application manifest.
Attachment #8423698 - Flags: review?(fabrice)
Flags: needinfo?(fabrice)
Comment on attachment 8423698 [details] [diff] [review]
Bug_1011393-Add-support-for-csp-entries-in-Manifest-Helper.patch

Review of attachment 8423698 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch, thanks!
Attachment #8423698 - Flags: review?(fabrice) → review+
Flags: needinfo?(fabrice)
Keywords: checkin-needed
Hi,
could you provide a Try link. Suggestions for what to run if you haven't
yet can be found here:
https://wiki.mozilla.org/Sheriffing/How:To:Recommended_Try_Practices
Assignee: nobody → vlatko.markovic
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed
(In reply to Carsten Book [:Tomcat] from comment #4)
> Hi,
> could you provide a Try link. Suggestions for what to run if you haven't
> yet can be found here:
> https://wiki.mozilla.org/Sheriffing/How:To:Recommended_Try_Practices

Hi,

I don't have the needed privileges to push commits to Try server.
Could you help out with that?
Flags: needinfo?(cbook)
Whiteboard: [autoland-$branch:8423698:-b o -p linux32_gecko,linux64_gecko,macosx64_gecko,win32_gecko -u marionette,mochitests -t none]
Hi Vlatko,

for the try access please see http://www.mozilla.org/hacking/committer/ for how to file a bug etc 

If that Bug is filed someone need to vouch, that could be as example fabrice since he already reviewed your patch here, you can post this bug number also here
Flags: needinfo?(cbook)
Whiteboard: [autoland-$branch:8423698:-b o -p linux32_gecko,linux64_gecko,macosx64_gecko,win32_gecko -u marionette,mochitests -t none] → [autoland-try:8423698:-b o -p linux32_gecko,linux64_gecko,macosx64_gecko,win32_gecko -u marionette,mochitests -t none]
Blocks: 1059221
Blocks: 1059204
No longer blocks: 1059204
Blocks: 1059202
https://hg.mozilla.org/mozilla-central/rev/bdece75d7f5e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Blocking a THA blocker.
blocking-b2g: --- → 2.1+
Whiteboard: [autoland-try:8423698:-b o -p linux32_gecko,linux64_gecko,macosx64_gecko,win32_gecko -u marionette,mochitests -t none]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.