Closed Bug 1011490 Opened 5 years ago Closed 5 years ago

Use MozMap for InstallTrigger

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Whiteboard: p=2 s=it-32c-31a-30b.3 [qa-])

Attachments

(1 file)

Per bug 1007878 comment #0.
Flags: needinfo?
Flags: needinfo?
This was surprisingly easy. Thanks, Boris!
Attachment #8424119 - Flags: review?(dtownsend+bugmail)
Attachment #8424119 - Flags: review?(bobbyholley)
Comment on attachment 8424119 [details] [diff] [review]
use mozmap for installtrigger parameters,

Review of attachment 8424119 [details] [diff] [review]:
-----------------------------------------------------------------

Beautiful
Attachment #8424119 - Flags: review?(dtownsend+bugmail) → review+
Comment on attachment 8424119 [details] [diff] [review]
use mozmap for installtrigger parameters,

Review of attachment 8424119 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #8424119 - Flags: review?(bobbyholley) → review+
I suck at tryserver syntax, so repushed as: remote:   https://tbpl.mozilla.org/?tree=Try&rev=f040c2048e77


(see also: bug 1011700)
(In reply to :Gijs Kruitbosch from comment #5)
> I suck at tryserver syntax, so repushed as: remote:  
> https://tbpl.mozilla.org/?tree=Try&rev=f040c2048e77
> 
> 
> (see also: bug 1011700)

Hrmpf, test failures. Trivial fix is re-instating part of the manual arg checking I did. I'll land with that adjusted after confirming it fixes that test failure, now that bug 1007878 has landed.
Whiteboard: p=2
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/8ceca2270d83
Status: NEW → ASSIGNED
Flags: firefox-backlog+
Whiteboard: p=2 → [fixed-in-inbound] p=2
Marco, this will need merging to m-c and uplift before we're done, so can you add this as pre-emptive carry-over to the upcoming iteration? Thanks!
Flags: needinfo?(mmucci)
Added to Iteration 32.2
Flags: needinfo?(mmucci)
Whiteboard: [fixed-in-inbound] p=2 → [fixed-in-inbound] p=2 s=it-32c-31a-30b.2 [qa?]
Whiteboard: [fixed-in-inbound] p=2 s=it-32c-31a-30b.2 [qa?] → [fixed-in-inbound] p=2 s=it-32c-31a-30b.3 [qa?]
Whiteboard: [fixed-in-inbound] p=2 s=it-32c-31a-30b.3 [qa?] → [fixed-in-inbound] p=2 s=it-32c-31a-30b.3 [qa-]
https://hg.mozilla.org/mozilla-central/rev/8ceca2270d83
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Status: RESOLVED → VERIFIED
Comment on attachment 8424119 [details] [diff] [review]
use mozmap for installtrigger parameters,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: N/A
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low due to test coverage
String or IDL/UUID changes made by this patch: none
Attachment #8424119 - Flags: approval-mozilla-aurora?
Gijs - Given that this isn't a regression and from your approval request doesn't have user impact, can you please comment on the benefit of uplifting this change to Aurora?
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8424119 [details] [diff] [review]
use mozmap for installtrigger parameters,

Aurora approval granted.

Spoke with Gijs offline. This fix is beneficial to get in for the next ESR train.
Attachment #8424119 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(gijskruitbosch+bugs)
https://hg.mozilla.org/releases/mozilla-aurora/rev/092373432ba2
Whiteboard: [fixed-in-inbound] p=2 s=it-32c-31a-30b.3 [qa-] → p=2 s=it-32c-31a-30b.3 [qa-]
You need to log in before you can comment on or make changes to this bug.