Closed Bug 1011518 Opened 7 years ago Closed 7 years ago

Blobber upload fails for compressed files on Windows.

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jgraham, Assigned: jgraham)

References

()

Details

Attachments

(2 files, 1 obsolete file)

Failure messages look like 

17:51:00     INFO -  IOError: [Errno 13] Permission denied: 'c:\\docume~1\\cltbld~1.t-x\\locals~1\\temp\\tmp6yk8ik'

This appears to be due to trying to get two handles to a single temporary file. Patch on GitHub.
Attachment #8423884 - Flags: review?(ted)
Comment on attachment 8423884 [details] [review]
Patch to just use a single file handle for compressed files

I tested this with blobberc on Windows and it worked fine for a file that got compressed (.txt), a file that didn't get compressed (.png), and a file that got served with content-disposition attachment (.zip).

Can't believe I wrote the code like that, I've definitely encountered this footgun before.
Attachment #8423884 - Flags: review?(ted) → review+
I think some of the confusion of that code was from before I fiddled things to pass the filename down to post_file, so it may have been unnecessarily complex.
Assignee: nobody → james
What has to happen to land this / get it into production?
mtabara needs to merge that PR, and release a new version to pypi, then someone in releng-land needs to put a new tarball in tooltool and bump the version in mozharness (I know this from getting bug 962356 deployed).

mtabara, rail: can you two make that happen?
Flags: needinfo?(tabara.mihai)
Merged the PR. Released a new version: 1.1.4 (tar ball here - https://pypi.python.org/pypi/blobuploader/ )
Patched mozharness below for after new tar all gets into Moz repo.
Flags: needinfo?(tabara.mihai)
Released a new version of blobuploader (1.1.5) with changes for bug 998796.
Tar ball, as usual - here: https://pypi.python.org/pypi/blobuploader/
Re-patched mozharness below.
Just a brief reminder, this patch is to be deployed *after*:
1. Blobber server EB2 restart with new changes (bug 998796)
2. Blobuploader tar ball (1.1.5) puppetized in toolttool
Attachment #8424426 - Flags: review?(rail)
Thanks!

Is there anything I need to do to push this along? Otherwise do we have an ETA on getting the updates deployed? I have some worked blocked on this so it's helpful to know if it will be days or weeks.
It's a matter of 1-2 days usually if there is norhing more urgent in the queue.
Lemme ping Rail about this.
Flags: needinfo?(rail)
I'll deploy all the things tomorrow. Canada is off today ;)
Flags: needinfo?(rail)
Comment on attachment 8424292 [details] [diff] [review]
Bump blobuploader version to 1.1.4

The next patch obsoletes this one
Attachment #8424292 - Attachment is obsolete: true
Attachment #8424292 - Flags: review?(rail)
Comment on attachment 8424426 [details] [diff] [review]
Bump blobuploader version to 1.1.5

https://hg.mozilla.org/build/mozharness/rev/98c98ca24f41

default only
Attachment #8424426 - Flags: review?(rail)
Attachment #8424426 - Flags: review+
Attachment #8424426 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.