Closed Bug 1011550 Opened 7 years ago Closed 7 years ago

include device in fota mar filenames

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(firefox30 wontfix, firefox31 wontfix, firefox32 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
Tracking Status
firefox30 --- wontfix
firefox31 --- wontfix
firefox32 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

Attachments

(3 files)

We did this already for OTAs, but not FOTAs.
There's a risk that we'd accidentally upload a full FOTA if we ever hit a case where we only generate it. AFAICT we only generate gecko+gaia FOTAs right now. We'd still be safe if we started generating full in addition to those, because query_marfile_path would throw an error about finding too many MARs.

I could add a "if full in filename" guard here, but that would prevent fotas from getting uploaded anywhere (including private places).

This would all be a lot easier and safer if we could put logic into the b2g build system, or pluck variables out of it. Without one of those we have to do crappy things like glob *.mar in the list of upload files.
Attachment #8423926 - Flags: review?(aki)
Comment on attachment 8423926 [details] [diff] [review]
be less fussy about fota mar filename

I'd love if you could list the mars in the fatal().  Could be as verbose as

self.fatal("Found none or too many marfiles in %s, don't know what to do:\n%s" % (mardir, str(mars)), exit_code=1)

or something.  Because I'm lazy and don't want to have to ssh into the box.
Attachment #8423926 - Flags: review?(aki) → review+
(In reply to Aki Sasaki [:aki] from comment #2)
> Comment on attachment 8423926 [details] [diff] [review]
> be less fussy about fota mar filename
> 
> I'd love if you could list the mars in the fatal().  Could be as verbose as
> 
> self.fatal("Found none or too many marfiles in %s, don't know what to
> do:\n%s" % (mardir, str(mars)), exit_code=1)
> 
> or something.  Because I'm lazy and don't want to have to ssh into the box.

Good idea, I'll add that.
Comment on attachment 8423926 [details] [diff] [review]
be less fussy about fota mar filename

Landed w/ the fatal() message.
Attachment #8423926 - Flags: checked-in+
Something here went live today
Balrog submission failed for Hamachi and turned the build red:
05:28:36    FATAL - Couldn't find complete mar url in config or package_urls
05:28:36    FATAL - Running post_fatal callback...
05:28:36    FATAL - Exiting -1
Failed similarly for Nexus 4, too.
This actually might be an issue with the dated dirs patch, not this one...
Indeed. This one is fine, the problem is actually in bug 1011486.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whoops, can't close this bug until I actually change the Gonk build system....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This is pretty much the same as what we did for OTA mars. Build scripts have been updated to cope, so this should be able to be merged at any time.
Attachment #8427964 - Flags: review?(dhylands)
Comment on attachment 8427964 [details] [review]
include device name in FOTA mars

Looks good to me.
Attachment #8427964 - Flags: review?(dhylands) → review+
So the MARs are being generated with the right names now, but this glob isn't catching them, so they're not being uploaded.
Attachment #8430032 - Flags: review?(aki)
Attachment #8430032 - Flags: review?(aki) → review+
All good now. We've got MARs like http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2014-05-29-04-02-01-mozilla-central-hamachi/fota-hamachi-update.mar, and Balrog is pointing at them.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Comment on attachment 8427964 [details] [review]
include device name in FOTA mars

Drivers, I'd like to backport both patches here to b2g30 so that we can use our new update server, which is more reliable and enables better compatibility with Socorro for crash reports.

There were no issues when this landed on master.
Attachment #8427964 - Flags: approval-mozilla-b2g30?
Attachment #8427964 - Flags: approval-mozilla-b2g30? → approval-mozilla-b2g30+
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.