Closed Bug 1011612 Opened 8 years ago Closed 8 years ago

[B2G][Open_C][Homescreen] Default smart collections are missing their icons showing a placeholder icon instead

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 affected)

RESOLVED DUPLICATE of bug 1008586
Tracking Status
b2g-v1.4 --- affected

People

(Reporter: jschmitt, Unassigned)

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Attached image Placeholder.png
Description:
The Smart Collection icons are replaced with the placeholder icon.

Repro Steps:
1) Update a Open_C to BuildID: 20140516000201
2) Turn phone on and proceed to Homescreen
3) Proceed to the 1st homescreen page

Actual:
The smart collection icons are missing.

Expected:
The smart collection icons are displayed.

1.4 Environmental Variables:
Device: Open_C 1.4
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

Notes:
Repro frequency: 100%
See attached: screenshot

Will add buri results shortly
blocking-b2g: --- → 1.4?
QA Contact: ddixon
Issue does not repro on 1.4 Buri. Also 2.0 Open_C is not affected.

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: v1.2-device.cfg
Summary: [B2G][Homescreen] Default smart collections are missing their icons showing a placeholder icon instead → [B2G][Open_C][Homescreen] Default smart collections are missing their icons showing a placeholder icon instead
1.4 Flame Regression Window

Last Working:
Environmental Variables:
Device: Open_C 1.4
BuildID: 20140515123001
Gaia: 8806eebe8f1555b1f924166f921ab831a5e3560c
Gecko: 366af94890cf
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

First Broken:
Environmental Variables:
Device: Open_C 1.4
BuildID: 20140515183003
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 8806eebe8f1555b1f924166f921ab831a5e3560c
Gecko: a1e455367fa6

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: 366af94890cf

https://github.com/mozilla-b2g/gaia/compare/8806eebe8f1555b1f924166f921ab831a5e3560c...32fca83da31b9a0f9a5a88f96c913a25accdc14b
Keywords: smoketest
The window here points to a push log with no code changes. Can we double check this?
Confirming test results from comment 2 - have the same results: last working build, first broken build, swap confirms Gaia issue and pushlog is correct:
https://github.com/mozilla-b2g/gaia/compare/8806eebe8f1555b1f924166f921ab831a5e3560c...32fca83da31b9a0f9a5a88f96c913a25accdc14b

This issue didn't reproduce on yesterday's 1.4 smoketest build, and occurred on today's, so attaching Gaia pushlog using Nighly buids in case it can be helpful:
https://github.com/mozilla-b2g/gaia/compare/2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab...32fca83da31b9a0f9a5a88f96c913a25accdc14b
Keywords: qaurgent
I think this might be a build problem. I'm going to suggest that we retest this on the next build available to see if this still happens.
Keywords: qawanted
There's also

-  <project name="apitrace" path="external/apitrace" remote="apitrace" revision="59befcef1763a403525e99dc9e8d6c0e1d676806"/>
+  <project name="apitrace" path="external/apitrace" remote="apitrace" revision="8a4baf82a131a7853cf7e7f9cf74253927b2f355"/>

-  <project name="device-flame" path="device/t2m/flame" remote="b2g" revision="b1d23890531de539e47e594e07e06b2dca54a85b"/>
+  <project name="device-flame" path="device/t2m/flame" remote="b2g" revision="bbbeb3aeb0ae9f209eb8abe48a71f37e568b63af"/>
(In reply to Aki Sasaki [:aki] from comment #6)
> There's also
> 
> -  <project name="apitrace" path="external/apitrace" remote="apitrace"
> revision="59befcef1763a403525e99dc9e8d6c0e1d676806"/>
> +  <project name="apitrace" path="external/apitrace" remote="apitrace"
> revision="8a4baf82a131a7853cf7e7f9cf74253927b2f355"/>
> 
> -  <project name="device-flame" path="device/t2m/flame" remote="b2g"
> revision="b1d23890531de539e47e594e07e06b2dca54a85b"/>
> +  <project name="device-flame" path="device/t2m/flame" remote="b2g"
> revision="bbbeb3aeb0ae9f209eb8abe48a71f37e568b63af"/>

Those seem like somewhat small changes.
(In reply to Jason Smith [:jsmith] from comment #5)
> I think this might be a build problem. I'm going to suggest that we retest
> this on the next build available to see if this still happens.

Issue DOES reproduce on latest 1.4 build.

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140516063007
Gaia: 7019efdbcfa58d3ff4702b018420db3d8753bb93
Gecko: b9cfcf60d707
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
Keywords: qawanted
(In reply to ddixon from comment #9)
> (In reply to Jason Smith [:jsmith] from comment #5)
> > I think this might be a build problem. I'm going to suggest that we retest
> > this on the next build available to see if this still happens.
> 
> Issue DOES reproduce on latest 1.4 build.
> 
> Environmental Variables:
> Device: Open_C 1.4
> BuildID: 20140516063007
> Gaia: 7019efdbcfa58d3ff4702b018420db3d8753bb93
> Gecko: b9cfcf60d707
> Version: 30.0
> Firmware Version: P821A10V1.0.0B06_LOG_DL

The next build available, not today's build...
Keywords: qawanted
Still reproduces on the 2nd build available today.
Keywords: qawanted
According to Cristian, this is the same problem as bug 1008586.
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008586
You need to log in before you can comment on or make changes to this bug.