Closed Bug 1012443 Opened 6 years ago Closed 6 years ago

AttributeError: 'MacOSXOSAScript' object has no attribute 'basename'

Categories

(Add-on SDK Graveyard :: General, defect, P2)

x86_64
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: m+bugzilla, Assigned: m+bugzilla)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
zombie
: review+
Details | Review
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140516030204

Steps to reproduce:

$ cfx


Actual results:

Traceback (most recent call last):
  File "/Applications/Mozilla Addon SDK/bin/cfx", line 30, in <module>
    import cuddlefish
  File "/Applications/Mozilla Addon SDK/python-lib/cuddlefish/__init__.py", line 8, in <module>
    import webbrowser
  File "/usr/local/Cellar/python/2.7.6_1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/webbrowser.py", line 669, in <module>
    cmd = _synthesize(cmdline, -1)
  File "/usr/local/Cellar/python/2.7.6_1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/webbrowser.py", line 94, in _synthesize
    if controller and name.lower() == controller.basename:
AttributeError: 'MacOSXOSAScript' object has no attribute 'basename'


Expected results:

Working.
OS: All → Mac OS X
Hardware: All → x86_64
Severity: normal → critical
it doesn't look webbrowser is actually used anywhere in the code, so maybe just take out that import line from __inti__.py ?
Severity: critical → normal
Perfect @Tomislav, it works like a charm now.
Attached file Fix cfx crash
Attachment #8424834 - Flags: review?(tomica+amo)
Assignee: nobody → m+bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8424834 - Flags: review?(tomica+amo) → review+
hey Erwann, could you please rename the commit title to something like "bug 1012443 - remove unneeded import from cfx". we try to keep our commit logs meaningful and readable.

if you are interested in contributing some more, here is a guide and a list of good first bugs:

https://github.com/mozilla/addon-sdk/wiki/contribute
https://bugzilla.mozilla.org/buglist.cgi?product=Add-on+SDK&status_whiteboard=[good+first+bug]
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/2ee71ac1497f9459e6b112d18f3df69fd3c06b1d
bug 1012443 - remove unneeded import from cfx

https://github.com/mozilla/addon-sdk/commit/6d4fd8a1f473b6019766e68f926f3ef520556eb2
Merge pull request #1494 from kud/patch-1

bug 1012443 - remove unneeded import from cfx, r=@zombie
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Glad to have done my first patch, guys! ;)
Hey Jeff, this bug apparently didn't land in 1.16, so the issue is still present in release.
It seems a bit critical, however because is related to cfx only, devs can actually use the master version, without override the modules, and therefore uses only the command line tool from the repo and the modules from the browser, in order to make the AMO reviewers happy – that doesn't accept add-ons from master.

Due the fact that we're going to remove cfx in the future, I was thinking if it's worthy to release another cfx version for this bug or not. I think it's your call.
Flags: needinfo?(jgriffiths)
The thing is if you want to develop an addon on macosx with 1.16, you'll get an error which crashes cfx and won't be able to release your addon. Yes, it is critical in my opinion.
(In reply to Matteo Ferretti [:matteo] [:zer0] from comment #8)
> Hey Jeff, this bug apparently didn't land in 1.16, so the issue is still
> present in release.
> It seems a bit critical, however because is related to cfx only, devs can

Matteo, did you run into this issue as well?

if not, i don't think this is critical, as there is only one known user that it affects (Erwann above). that part of code hasn't changed in years, so if it wasn't just an issue with Erwann's setup, we would probably have a lot more devs complaining.

the simple solution is to just use the released 1.16 and comment out that one line when releasing to AMO.
By the way, do you know why I've got this error in fact?
(In reply to Erwann Mest from comment #9)
> Yes, it is critical in my opinion.

well, calling something slightly inconvenient/annoying to one user as "critical" is a bit disingenuous in my opinion. 


> By the way, do you know why I've got this error in fact?

i have no idea (i don't use OSX), but as i said, you are the only user who reported this error. 

and it's not like OSX is an untested platform -- most, if not all (apart for me) of the jetpack team use it as their primary platform.
okay okay, thank you for your explanation. ;)
(In reply to Matteo Ferretti [:matteo] [:zer0] from comment #8)
> Hey Jeff, this bug apparently didn't land in 1.16, so the issue is still
> present in release.
> It seems a bit critical, however because is related to cfx only, devs can
> actually use the master version, without override the modules, and therefore
> uses only the command line tool from the repo and the modules from the
> browser, in order to make the AMO reviewers happy – that doesn't accept
> add-ons from master.
> 
> Due the fact that we're going to remove cfx in the future, I was thinking if
> it's worthy to release another cfx version for this bug or not. I think it's
> your call.

Given that jpm is close enough ( and the workaround of using master is easy enough for more advanced users ) that I do not want to do another release.
Flags: needinfo?(jgriffiths)
You need to log in before you can comment on or make changes to this bug.