Closed Bug 1012674 Opened 8 years ago Closed 6 years ago

olivocaffe.com - CSS Z-index and overflow:hidden, menus are not showing up.

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(firefox32 affected)

RESOLVED FIXED
Tracking Status
firefox32 --- affected

People

(Reporter: chiorean.ioana, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [country-ro] [css])

Attachments

(3 files)

Attached image Fx vs Chronium
Ubuntu 12.04 x64 using Nightly 

Steps:
1. http://www.olivocaffe.com/
2. Refresh
3. Try step 1 using Chronium (or Chrome etc..)

Actual Results: 
- After step 1 only a slideshow with pic is displayed.
- after refreshing you see the menu for like 2secs. 

Expected Results:
- there should be displayed a navigation menu like it is on  other browsers.
Attached image while refreshing
Flags: needinfo?(mihaela.velimiroviciu)
Can you find a regression range? This looks like another dupe of bug 1010783.
The issue can be reproduced also on Firefox 29 and 31. Not related to Bug 1010783. Tech Evang.
Assignee: nobody → romanian
Component: General → Romanian
OS: Linux → All
Product: Firefox → Tech Evangelism
Hardware: x86_64 → All
Changing the z-index of #wrapper to 99 will resolve the issue. Chrome/Safari/Opera works as expected. Gecko's implementation is wrong?
Attached file Olivo Caffe demo
This is about whether overflow:hidden elements have a separate z-index stacking context .. or something? It rings a bell, and I have boiled down a standalone demo with less than half of the code and no JS .. but I can't describe it in real detail..
Flags: needinfo?(dbaron)
Yes that requires a bit more investigation.
Confirmed for the bug.
Assignee: romanian → nobody
Component: Romanian → Desktop
Summary: Missing elements in page → olivocaffe.com - Missing elements in page
Whiteboard: [country-ro] [css]
Summary: olivocaffe.com - Missing elements in page → olivocaffe.com - CSS Z-index and overflow:hidden, menus are not showing up.
Flags: needinfo?(mihaela.velimiroviciu)
This appears to be fixed now. Tested in Firefox 49 on OSX and 46 in Ubuntu.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.