Dead keys does not work under KDE

NEW
Assigned to

Status

()

P4
normal
17 years ago
9 years ago

People

(Reporter: jozef.chocholacek, Assigned: jshin1987)

Tracking

({intl})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have RedHat7.1cz (Czech) on my computer and KDE2.2 over it and dead keys does
not work in any of Mozilla components. When I switch my keyboard to Czech or
Slovak, then by pressing '=a' the result should be 'á', but it is '´a', or by
pressing '+z' the result should be '¾' but it is '·z'.
It seems to me similar to bugs #63717 and #20932, but they are marked resolved
and 'worksforme' and I cannot agree.
(Note: keyboards are selected via KDE control center, browser: Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:0.9.4) Gecko/20010913.)

Comment 1

17 years ago
assiging Linux i18n bug to bstell
Assignee: yokoyama → bstell
Keywords: intl

Comment 2

17 years ago
qa -> ruixu.  Rui, please confirm.
QA Contact: andreasb → ruixu

Comment 3

17 years ago
I try the following
1. got o /usr/share/xmodmap
2. type xmodmap xmodmap.cz
then I can type
'=a' => 'á'
'+z' still equal to '·z'
but the xmodmap.cz said 

keycode  21 = dead_acute caron dead_cedilla
which mean the "+" sign SHOULD be acaron (not a dead_caron)
the dead_caron is in 
keycode  11 = ecaron 2 dead_caron

also, 
I change the xmodmap.cz in my system to
keycode  11 = dead_caron 2  ecaron 
and try to type "2" "z" to get a '¾', but I still cannot. 

It seems we have problem with dead_caron, it seems other dead key which generate 
ISO-8859-1 characters have no problem. 

Assignee: bstell → ftang

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

17 years ago
what will hapeen if you start mozilla under cz locale ?

Updated

17 years ago
Priority: -- → P4
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
can you tell me is there any other app will do the right thing ?
(Reporter)

Comment 6

17 years ago
My locale is cs_CZ (Czech, LANG=cs, LC_ALL=cs_CZ), and it is the environment
where it doesn't work. KDE apps, like e.g. KEdit work good, also GEdit from
Gnome apps works good. Not enough time to test more apps, sorry.

Updated

17 years ago
Keywords: mozilla1.0

Comment 7

17 years ago
we may want to do this before m1.0
Target Milestone: mozilla1.0 → ---

Comment 8

17 years ago
Switch to ISO-8859-2 before you read the rest:

ok, here is my "better" reproducing procedure: (in my RedHat 7.2)
1. login into linux as KDE
2. in the KDE desktop menu, select "(K)":"Preferences":"Perpharials":"Keyboard"
3. The "Keyboard" preference dialogbox show up.
4. deselect "Disable Keyboard Layouts"
5. check on "Czech", keep "U.S. English" as "Primary Layout"
6. click "OK"
7 [us] menu will show up in the lower right corner
8. left click to toggle to "Cz" or right click to bring up the menu and select "Cz
 for Czech

Now bring up mozilla,

below is what I work

'=' + 'a' = á
'=' + 'e' = é
'=' + 'i' = í
'=' + 'u' = ú
'=' + 'y' = ý
'\' + 'a' = ä
'\' + 'e' = ë
'\' + 'i' = 

Comment 9

17 years ago
really cannot reproduce the problem. Maybe due to mis communication. Can you put
down detailed, step by step, including image reprodue procedure ?

Comment 10

17 years ago
mark it work for me
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 11

17 years ago
Hi Jozef,

Could you please verify with the latest build to see if it is still 
reproducible? if yes, could you please provide us more detailed reproduce steps? 
Thanks!
(Reporter)

Comment 12

17 years ago
OKay, it still doesn't works for me, neither in 0.9.8 nor 0.9.9. Here is
description of my system:
 - RedHat 7.1cz (czech - almost everything is the same as in official rh7.1,
just some localization patches are applied);
 - KDE 2.1.1 (some of RPMS: kdebase-2.1.1-8cz1, kdelibs-2.1.2-1,
kde-i18n-Czech-2.1.1-2, kde-i18n-Slovak-2.1.1-2, kdesupport-2.1-3, ...)
 - in KDE Control center -> Personal setting -> Keyboard layout I have main
layout set to "U.S. English" and additional layouts "Czechoslovakian" (it means
Czech) and "Slovak"; I can switch between layouts pressing Ctrl+Alt+K;

  If you need some of my config files ask for them (I don't know what are
related to this problem).

  I will check this bug also home on my SuSE7.2cz box, there are other settings
(and KDE2.2.2).

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 13

17 years ago
Oh, and the buggy behavior is the same for all components - writing new mail,
filling html forms, changing preferences, ...
(Reporter)

Comment 14

17 years ago
So, I tried how it works on my home SuSE with KDE2.2.2 and there is no problem
(for both 0.9.8 and 0.9.9), so if no one else can reproduce this bug it is
probably just problem with my office box installation or configuration.

Comment 15

17 years ago
I have same problem running Mozilla 1.0RC1 on RH7.3. I do not use KDE and I am
not able to use dead keys to get proper letters from ISO Latin 2 charakter set.
I am not using xmodmap, but xkb. Maybe it is somehow related to RH.

Comment 16

17 years ago
on my Mandrake Cooker system; without KDE, international keyboard using via XKB,
keymap czsk, this works perfectly. i can write into any field (url bar, forms,
composer) any caron and accute letter. i think, this is redhat-specific
behavior, because on not one mailing list i see this problem, only with redhat
distro.
not very technical, but i believe that a little bit useful. i shall continue on
some research about this problem..

Comment 17

17 years ago
I found cause of this problems. It is not in locales or keymaps etc. but it is 
in fonts. This is my fs/config, # lines were previously uncomented. With this
config dead keys work in mozilla like they shloud. My secret favorit for
troubleshooter among these files is line /usr/X11R6/lib/X11/fonts/ttf, where I
had Arial font from MS. This was recommended somewhere for mozilla (and maybe
other applications) becasue RedHat Arial is really ugly.) So it seems to me like
that there is some problem with ttf+RH+mozilla.

catalogue = /usr/X11R6/lib/X11/fonts/75dpi:unscaled,
        /usr/X11R6/lib/X11/fonts/100dpi:unscaled,
        /usr/X11R6/lib/X11/fonts/misc:unscaled
        /usr/X11R6/lib/X11/fonts/Type1,
        /usr/X11R6/lib/X11/fonts/Speedo,
        /usr/X11R6/lib/X11/fonts/cyrillic,
        /usr/X11R6/lib/X11/fonts/CID,
#       /usr/X11R6/lib/X11/fonts/local,
#       /usr/share/fonts/default/TrueType,
#       /usr/share/fonts/default/Type1,
#       /usr/share/fonts/ja/TrueType,
#       /usr/share/fonts/ISO8859-2/misc:unscaled,
#       /usr/share/fonts/ISO8859-2/75dpi:unscaled,
#       /usr/share/fonts/ISO8859-2/100dpi:unscaled,
#       /usr/share/fonts/ISO8859-2/Type1,
#       /usr/share/fonts/ISO8859-2/Type1-URW,
#       /usr/X11R6/lib/X11/fonts/ttf,
        /usr/share/AbiSuite/fonts
(Reporter)

Comment 18

17 years ago
Hmmm, it does not work for me, Adam - I have removed almost all fonts from my
/etc/X11/fs/confing and /etc/X11/XF86Config but the behavior is still the same.
But because it works on my home SuSE box I just assume I have some strange RH
box in my office. May be it works for others.

Updated

17 years ago
Target Milestone: --- → Future

Updated

16 years ago
QA Contact: ruixu → ylong

Comment 19

14 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → WONTFIX

Comment 20

14 years ago
Mass Reassign Please excuse the spam
Assignee: ftang → nobody

Comment 21

14 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 22

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: amyy → i18n
You need to log in before you can comment on or make changes to this bug.