Closed Bug 1012795 Opened 6 years ago Closed 6 years ago

Replace editing mode cancel button telemetry extra with button id name

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- verified
firefox32 --- verified

People

(Reporter: mcomella, Assigned: mcomella)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Might need some rebasing - haven't pulled yet.
Attachment #8424999 - Flags: review?(mark.finkle)
Comment on attachment 8424999 [details] [diff] [review]
Pass resource ID name with editing mode cancel event.

Remember uplift
Attachment #8424999 - Flags: review?(mark.finkle) → review+
Comment on attachment 8424999 [details] [diff] [review]
Pass resource ID name with editing mode cancel event.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  bug 997487
 
User impact if declined:
  None directly, but it will make it more difficult for us to analyze the UI telemetry scripts and make our data inconsistent across versions - i.e. wasted developer effort

Testing completed (on m-c, etc.):
  Local.
 
Risk to taking this patch (and alternatives if risky):
  Minimal - if we mess up, we're just messing up the telemetry event's extras field even more, but it's unlikely. 

String or IDL/UUID changes made by this patch: None
Attachment #8424999 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/703fae2e244c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Attachment #8424999 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The following telemetry probe is logged when tapping on cancel button:
SendUIEvent: action = cancel.1 method = actionbar timestamp = 1084109 extras = edit_cancel

Verified as fixed in builds:
- 32.0a1 (2014-05-25);
- 31.0a2 (2014-05-25);

Device: Alcatel One Touch 8008D (Android 4.1.2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.