sched - Form Submission (POST) not implemented in Necko.

VERIFIED FIXED in M9

Status

()

P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: kyoung, Assigned: mcafee)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
In forms that contain a select statement, M8 will not pass the correct
information when a POSt is used, however a GET will work.

Updated

19 years ago
Assignee: karnaze → pollmann

Comment 1

19 years ago
Reassigning to Eric.

Comment 2

19 years ago
I could find no forms on www.orent.com  Do you have a specific test case?  If
so, please attach it to this bug report, thanks!

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

19 years ago
This works for me!  I'm attaching a working testcase and marking invalid.  If
you have a testcase that does not work, please reopen the bug and attach the
testcase, thanks!

Comment 4

19 years ago
Created attachment 935 [details]
Working test case.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 5

19 years ago
I tried to verify this using the attached testcase, and lo and behold, it
doesn't work for me. 1999072311 build (Necko build), M9, Windows NT 4 SP 5.
Reopening and clearing resolution.

Updated

19 years ago
Status: REOPENED → ASSIGNED

Comment 6

19 years ago
The non-Necko build I just checked out (current to the hour) worked fine.  This
must be a Necko specific problem  I'll check it out.

Comment 7

19 years ago
This is a Necko bug, er, lack of implementation.  See the following code in
nsDocLoader.cpp:

1561     /* Store any POST data into the URL */
1562     if (nsnull != aPostData) {
1563 #ifdef NECKO
1564         NS_ASSERTION(0, "FIX ME");
1565 #else
1566         static NS_DEFINE_IID(kPostToServerIID, NS_IPOSTTOSERVER_IID);
1567         nsIPostToServer* pts;
1568
1569         rv = url->QueryInterface(kPostToServerIID, (void **)&pts);
1570         if (NS_SUCCEEDED(rv)) {
1571             const char* data = aPostData->GetData();
1572
1573             if (aPostData->IsFile()) {
1574                 pts->SendDataFromFile(data);
1575             }
1576             else {
1577                 pts->SendData(data, aPostData->GetDataLength());
1578             }
1579             NS_RELEASE(pts);
1580         }
1581 #endif
1582     }

Updated

19 years ago
Assignee: pollmann → warren
Status: ASSIGNED → NEW
Component: Form Submission → Necko
OS: Windows NT → All
Hardware: PC → All
Summary: Form Submission (POST) not passing Select items → Form Submission (POST) not implemented in Necko.
Target Milestone: M9

Comment 8

19 years ago
Not sure who to assign this to, but POSTing data to a server doesn't work for
Necko.  The comment "Fix Me" was written by Warren so I'm giving it to him!
I'm willing to lend a hand, so if you need it, let me know.

Updated

19 years ago
Blocks: 7232

Updated

19 years ago
Blocks: 10730

Updated

19 years ago
Summary: Form Submission (POST) not implemented in Necko. → sched - Form Submission (POST) not implemented in Necko.

Comment 9

19 years ago
See related bug 9208

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 10

19 years ago
*** Bug 9208 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
Adding Steve and Myself to the cc list as we need this form submission (POST)
capability to test our Netcenter activation work.

Updated

19 years ago
Blocks: 9347

Comment 12

19 years ago
Chris Mcafee: Are you going to be able to help out with this? I've added an
NS_NewPostDataStream call to nsNeckoUtil.h that should allow you to get
started.

Comment 13

19 years ago
*** Bug 10439 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: warren → mcafee
Status: ASSIGNED → NEW

Comment 14

19 years ago
Reassigning to Chris. He was working on this and was assigned to the dup.

Comment 15

19 years ago
*** Bug 11245 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

19 years ago
Fixed.

test url is down for me.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 17

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.