Closed Bug 1013120 Opened 6 years ago Closed 6 years ago

[B2G][Calendar] Month View: should use calendar colors for dots and alarm icons

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
2.0 S2 (23may)

People

(Reporter: edchen, Assigned: mmedeiros)

References

Details

(Whiteboard: [p=2])

Attachments

(2 files)

Attached image Screenshot
[Environment]
Gaia      8a2352d5b7be27ec4b1ea18c680ebcd0b6d34348
Gecko     https://hg.mozilla.org/mozilla-central/rev/cb9f34f73ebe
BuildID   20140519160202
Version   32.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013

[Reproduce]
1. Launch calendar app
2. Set google account and Yahoo account
3. Add a event with google account
4. Add a event with Yajoo account

[Actual result]
Dots color are the same. 

[Expect result]
Dots color should be different with different account
Blocks: 951069
do we also need to change the color of the alarms?
Flags: needinfo?(edchen)
I think that it's unnecessary. Maight be we can consult UX team about this question.

Hi Harly,
As Miller mentioned, could you please give some feedback on this case.
Flags: needinfo?(edchen) → needinfo?(hhsu)
Hi Edward,
After checking with Peko, to have alarm color the same as account color was part of the visual design. Thanks.
Flags: needinfo?(hhsu)
Blocks: 950209
No longer blocks: 951069
Summary: [B2G][Calendar] There is displayed the same color dot with different account → [B2G][Calendar] Month View: should use calendar colors for dots and alarm icons
since it's a "simple fix" I went ahead and changed it.
Attachment #8426505 - Flags: ui-review?(hhsu)
Attachment #8426505 - Flags: review?(gaye)
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.0 S2 (23may)
Comment on attachment 8426505 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19499

Nice job, Miller.
Thanks
Attachment #8426505 - Flags: ui-review?(hhsu) → ui-review+
Comment on attachment 8426505 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19499

Great work Miller and thanks for sticking with it :)
Attachment #8426505 - Flags: review?(gaye) → review+
Landed on master https://github.com/mozilla-b2g/gaia/commit/bcfc33561c2f795b082b06e7ecefd8e135d380b7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [p=2]
(In reply to Gareth Aye [:gaye] from comment #6)
> Comment on attachment 8426505 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19499
> 
> Great work Miller and thanks for sticking with it :)

Er I meant this comment for the week view, but this changeset also looks good.
[Environment]
Gaia      6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko     https://hg.mozilla.org/mozilla-central/rev/545c35907eff
BuildID   20140526160203
Version   32.0a1
ro.build.version.incremental=76
ro.build.date=Mon Apr 14 14:02:50 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.