Closed Bug 1013383 Opened 11 years ago Closed 11 years ago

Rename want-issuer property to wantIssuer in navigator.mozId.watch()

Categories

(Firefox OS Graveyard :: FxA, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jedp, Assigned: jedp)

References

Details

navigator.mozId.watch() takes a dictionary of options, one of whose properties is "want-issuer". When set to "firefox-accounts", this causes the identity service to use firefox accounts instead of persona (the default). "want-issuer" is a bad name for this property. It should be a proper identifier. In its present form, "want-issuer" is inconsistent with our other property names (forceAuth), is a nuisance to developers, and is invalid according to the Web IDL spec, according to which it should be possible to implement BrowserID. I propose we change it while we still have the time to be wantIssuer.
Spoke with spenrose on IRC. Taking this.
Assignee: nobody → jparsons
Status: NEW → ASSIGNED
:ggp we want to make this change to the API; will this be ok with you and WMF if this goes into B2G 2.0? I believe there's a three week window remaining for 2.0.
Flags: needinfo?(ggoncalves)
spenrose suggests "useIssuer" rather than "wantIssuer", since we don't fall back on anything if we can't support the requested issuer.
Oh look at that. We appear to already have done this. Sorry, nothing to see here. Move along ... move along ...
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: needinfo?(ggoncalves)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.