transform-origin is not taken into account when CSS animating SVG elements

RESOLVED DUPLICATE of bug 923193

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 923193
3 years ago
3 years ago

People

(Reporter: dotnetCarpenter, Unassigned)

Tracking

({testcase})

31 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8425610 [details]
svg_css_animation.htm

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140520004002

Steps to reproduce:

1) Open Firefox and a webkit based browser
2) Go to: http://dabblet.com/gist/5375c186664df8524c0f in both


Actual results:

In the webkit browser you can change the transform-origin on line 25 and see that the CSS animation takes the origin into account when animating the polygons.
In Firefox, changing line 28, does nothing to the origin. The animation, always uses the top left as origin.


Expected results:

When transform-origin: center center, the animation should use the center of each polygon as origin.
Allowed values are: top, left, right, bottom and center.
Since the animation is only on the Y axes, only top, bottom and center makes sense in this context.
(Reporter)

Comment 1

3 years ago
http://hansmuller-webkit.blogspot.dk/2012/03/css-transform-origin-coming-to-svg.html
Blocks: 891074
Component: Untriaged → SVG
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
Webkit implementation blog post: http://hansmuller-webkit.blogspot.dk/2012/03/css-transform-origin-coming-to-svg.html
(Reporter)

Updated

3 years ago
No longer blocks: 891074
Keywords: testcase
(Reporter)

Updated

3 years ago
Depends on: 923193
(Reporter)

Comment 3

3 years ago
Reproducible in Firefox 30.0 (beta) on Mac OSX 10.9.2
OS: Windows 7 → All
Hardware: x86 → All

Comment 4

3 years ago
Fairly sure this is a duplicate of bug 923193.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923193
You need to log in before you can comment on or make changes to this bug.