Closed Bug 1013478 Opened 6 years ago Closed 6 years ago

Use GCC 4.8 by default if available

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla32

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file, 1 obsolete file)

Right now we default to GCC 4.7, but NDK r9 and above don't have 4.7 and have 4.8 instead. So we should default to 4.8 if available. GCC below 4.7 won't work because of recent changes [1].

[1] https://mail.mozilla.org/pipermail/mobile-firefox-dev/2014-May/000654.html
    https://mail.mozilla.org/pipermail/mobile-firefox-dev/2014-May/000655.html
This adds 4.8 to the list of compilers. It also removes unsupported ones so the build fails earlier rather than later.
Attachment #8425738 - Flags: review?(nalexander)
Comment on attachment 8425738 [details] [diff] [review]
Use GCC 4.8 on Android if available (v1)

Review of attachment 8425738 [details] [diff] [review]:
-----------------------------------------------------------------

wfm.
Attachment #8425738 - Flags: review?(nalexander) → review+
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Keywords: checkin-needed
(In reply to Jim Chen [:jchen :nchen] from comment #0)
> GCC below 4.7 won't work because of recent changes [1].

Arguably, those should be fixed.
Comment on attachment 8425738 [details] [diff] [review]
Use GCC 4.8 on Android if available (v1)

Review of attachment 8425738 [details] [diff] [review]:
-----------------------------------------------------------------

It's fine to use 4.8 if 4.7 is not there, but i don't think we should switch to 4.8 if 4.7 is available.
Attachment #8425738 - Flags: review-
(In reply to Mike Hommey [:glandium] from comment #3)
> (In reply to Jim Chen [:jchen :nchen] from comment #0)
> > GCC below 4.7 won't work because of recent changes [1].
> 
> Arguably, those should be fixed.

And it's a simple fix: bug 1013646.
I think it still makes sense to default to 4.8 if available. I verified that NDK r9x only have 4.8 and not 4.7, i.e. there's no NDK that has both 4.8 and 4.7.

Right now we default to 4.7 for exactly two NDK revs,
> r8e:    GCC 4.6
r8d, r8e: GCC 4.7
r8b, r8c: GCC 4.6
< r8b:    GCC 4.4.3

But I think it makes better sense if we default to 4.8 for newer revs,
> r8e:    GCC 4.8
r8d, r8e: GCC 4.7
r8b, r8c: GCC 4.6
< r8b:    GCC 4.4.3
Attachment #8427147 - Flags: review?(mh+mozilla)
Attachment #8425738 - Attachment is obsolete: true
Depends on: 1011680
Attachment #8427147 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/86de442c14a4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 32 → mozilla32
You need to log in before you can comment on or make changes to this bug.