Closed Bug 1013543 Opened 7 years ago Closed 7 years ago

Repainted whole browser window when toggle nglayout.debug.paint_flashing

Categories

(Core :: Layout, defect)

32 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 1013536

People

(Reporter: alice0775, Unassigned)

References

Details

Steps To Reproduce
1. Open about:config
2. toggle nglayout.debug.paint_flashing

Actual results:
Repainted whole browser window

Expected Results:
Repainted content area only

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d002d113feca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140507193441
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d1155f994a3a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140507195741
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d002d113feca&tochange=d1155f994a3a

Triggered by:
d1155f994a3a	Matt Woodrow — Bug 938395 - Enable single rect painting for d3d10. r=Bas
Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.18245)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
This was fixed by Bug 1013536
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013536
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.