Leak nsHttpConnectionMgr::nsConnectionHandle with pipelining enabled

RESOLVED FIXED in mozilla32

Status

()

Core
Networking: HTTP
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Jesse Ruderman, Assigned: mcmanus)

Tracking

(Blocks: 1 bug, {mlk, regression, testcase})

Trunk
mozilla32
x86_64
Mac OS X
mlk, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8425833 [details]
testcase

1. Set
     user_pref("network.http.pipelining", true);
2. Run Firefox with XPCOM_MEM_LEAK_LOG=2
3. Load the testcase
4. Quit Firefox

Result: trace-refcnt reports a leak of nsHttpConnectionMgr::nsConnectionHandle

Based on when I started seeing this, I'm guessing it's a regression from bug 378637.
Assignee: nobody → mcmanus
Component: Networking → Networking: HTTP
jesse thanks for finding this.

the issue is a latent bug made more obvious by 378637. I tried to fix it up in patch 15 of that bug, but my patch was wrong because I treated mConnection as a smart pointer when it was just a "type *".
Created attachment 8426245 [details] [diff] [review]
make nsHttpPipeline.mConnection a smart pointer
Attachment #8426245 - Flags: review?(hurley)
 https://tbpl.mozilla.org/?tree=Try&rev=952fd8fdd483
Attachment #8426245 - Flags: review?(hurley) → review+
   https://hg.mozilla.org/integration/mozilla-inbound/rev/22e8c11b2108
https://hg.mozilla.org/mozilla-central/rev/22e8c11b2108
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.