in-content preferences advanced pane: remove text shadow from sub categories

VERIFIED FIXED in Firefox 32

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: soeren.hentzschel, Assigned: Paenglab)

Tracking

(Blocks 1 bug)

Trunk
Firefox 32
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 verified)

Details

Attachments

(2 attachments, 4 obsolete attachments)

Please remove the text shadow of the in-content preferences advanced panel sub category labels, it difficult to read, see screenshot.
Blocks: 738796
Posted patch horizontalTabs.patch (obsolete) — Splinter Review
This patch uses the styles from Project Chameleon.

I had to change the pane background-color to white like Chameleon to let the tabs look better. And this needed on Windows to remove the caption background color. On OS X I removed also the line below the captions.

On Project Chameleon where was no spec for the dimensions and I choosed the best fitting ones.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8430737 - Flags: review?(jaws)
Posted patch horizontalTabs.patch (obsolete) — Splinter Review
Found on Project Chameleon under Navigation - Horizontal inContent Navigation a different tabs background color for not active tabs. And also a updated transition.
Attachment #8430737 - Attachment is obsolete: true
Attachment #8430737 - Flags: review?(jaws)
Attachment #8430815 - Flags: review?(jaws)
Comment on attachment 8430815 [details] [diff] [review]
horizontalTabs.patch

Review of attachment 8430815 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/incontentprefs/preferences.css
@@ +102,5 @@
>  }
>  
> +tab:hover {
> +  background-color: #ebebeb;
> +}  

nit: trailing whitespace

@@ +108,3 @@
>  tab[selected] {
> +  background-color: #ebebeb;
> +  box-shadow: inset 0 -4px 0 0 #ff9500;

The linux theme adds a few rules for tab[selected] which need to be overriden.

Can you add a rule to the browser/themes/linux/incontentprefs/preferences.css for
tab[selected] {
  /* Override the margin-bottom for tab[selected]
     from toolkit/themes/linux/global/tabbox.css */
  margin-bottom: 0;
  border-bottom-left-radius: 0;
  border-bottom-right-radius: 0;
}
Attachment #8430815 - Flags: review?(jaws) → review-
Posted patch horizontalTabs.patch (obsolete) — Splinter Review
Fixed comments and updated after landing of bug 1013904.
Attachment #8430815 - Attachment is obsolete: true
Attachment #8431862 - Flags: review?(jaws)
Posted patch horizontalTabs.patch (obsolete) — Splinter Review
Found on OS X a unwanted padding on tabs. Removed with this patch.
Attachment #8431862 - Attachment is obsolete: true
Attachment #8431862 - Flags: review?(jaws)
Attachment #8432238 - Flags: review?(jaws)
Comment on attachment 8432238 [details] [diff] [review]
horizontalTabs.patch

Review of attachment 8432238 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the following changes.

::: browser/themes/linux/preferences/in-content/preferences.css
@@ +4,5 @@
>  
>  %include ../../../shared/incontentprefs/preferences.css
>  
> +tab[selected] {
> +  /* Override the margin-bottom for tab[selected]

This comment should just be made more generic since we are overriding not just the margin-bottom but also the border-radii from toolkit. You can just change it to /* Override styles for tab[selected] from toolkit/themes/linux/global/tabbox.css */

::: browser/themes/shared/incontentprefs/preferences.css
@@ +110,5 @@
>  }
>  
>  tab[selected] {
> +  background-color: #ebebeb;
> +  box-shadow: inset 0 -4px 0 0 #ff9500;

There is still a text-shadow on OSX with this patch applied. Please add a rule for `text-shadow: none;`.
Attachment #8432238 - Flags: review?(jaws) → review+
Fixed the comments.

Try: https://tbpl.mozilla.org/?tree=Try&rev=798689fed57d
Attachment #8432238 - Attachment is obsolete: true
Attachment #8432705 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a81285b5fabf
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Verified fixed on Mac OSX 10.8.5 using latest Nightly 32.0a1 (buildID: 20140609030202).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.