Closed Bug 1013796 Opened 5 years ago Closed 5 years ago

Make TraceGlobal deal with partially created global object

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: peterv, Assigned: peterv)

References

Details

Attachments

(1 file)

Attached patch v1Splinter Review
A little sad that we have to null-check, but the JS_NewGlobalObject call can GC, and at that point we haven't set up the XPCWrappedNativeScope.
Attachment #8426066 - Flags: review?(bzbarsky)
Duplicate of this bug: 1012900
Duplicate of this bug: 1012974
Comment on attachment 8426066 [details] [diff] [review]
v1

r=me
Attachment #8426066 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/322657b30d55
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.