Closed Bug 1013903 Opened 7 years ago Closed 6 years ago

Remote debug of webapps running in desktop webapp runtime is broken

Categories

(DevTools :: Debugger, defect)

32 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1014141

People

(Reporter: clochix, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: Desktop WebRT)

STR:
 - install a web app;
 - go to the ~/.xxxx folder where it is installed
 - try to launch with remote debug: `./webapprt-stub -debug 6000`;

Expected result:
 - with an OWA installed from Firefox 29, it just works;
 - on Nightly, i get this error message:

    Error loading: chrome://webapprt/content/dbg-webapp-actors.js:
    at chrome://webapprt/content/dbg-webapp-actors.js : 50
    ReferenceError: BrowserTabList is not defined - @chrome://webapprt/content/dbg-webapp-actors.js:50:1
    loadSubScript@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:67:5
    DS_addActors@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:303:5
    this.RemoteDebugger.init@resource://app/modules/RemoteDebugger.jsm:22:7
    handle@resource://app/components/CommandLineHandler.js:27:7

(FTR, remote debug in webapp runtime was enabled by #777428 )
Keywords: regression
Whiteboard: Desktop WebRT
Bug 1010750 will fix some of it, but dbg-webapp-actors.js will need similar changes to those in dbg-browser-actors.js from that patch. Do you feel like creating a patch for this?
Depends on: 1010750
I believe this was resolved by the changes in bug 1014141, so marking this as a dupe.  I am not able to reproduce the issue anymore.

Please reopen if the problem is still present.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014141
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.