Closed Bug 1013951 Opened 7 years ago Closed 7 years ago

Evernote authentication has stopped working in Notes+ in 1.4 onwards

Categories

(Firefox OS Graveyard :: Gaia::Notes, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
2.0 S2 (23may)

People

(Reporter: cwiiis, Assigned: doliver)

Details

Attachments

(1 file)

44 bytes, text/x-github-pull-request
yor
: review+
Details | Review
Syncing the 'Notes+' app (by Mozilla) with Evernote has stopped working in 1.4 and onwards. It still works correctly in 1.3. After authorising, in 1.4/master you're presented with a blank page and nothing happens. In 1.3, it correctly closes and goes back to the app, where syncing commences.
It's worth noting that for each authorisation, I still get the e-mail saying that it was granted, it's just the app doesn't seem to acknowledge it.
Attached file phase2 PR
Ouch. Bad code, bad review, bad test on our last update. This should fix it.
Assignee: nobody → doliver
Status: NEW → ASSIGNED
Attachment #8426443 - Flags: review?(yor)
Attachment #8426443 - Flags: review?(yor) → review+
Keywords: checkin-needed
phase2: https://github.com/mozilla-b2g/notes/commit/8a31051535f180024557e9cc721a391936138167
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S2 (23may)
Thanks :cwiiis. This fix is now live in the marketplace, Notes+ v2.2.4.
Great, fast work! I couldn't force it to update (is there a way of doing this? Checking for updates did nothing, I'm sure that used to work in 1.3...), but uninstalling it and reinstalling it, I can verify it's fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.