If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Printing crashes netscape

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Peter Flass, Assigned: mkaply)

Tracking

({crash})

Trunk
x86
OS/2
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Warpzilla build 1002092011
Mozilla 0.9.4+
Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:0.9.4+) Gecko/20010920
Printing crashes the browser.  It looks like a branch or call to location 0, but
I don't want to try it again until I get this bug report in.
System: OS/2 Warp 4 XR0M009
Printer: Tried 2 - HP Laserjet III PCL driver and Postscript Laserjet 4.

Could this be an installation issue?  The package I downloaded came with no
installation instructions.  I just unzipped it and started running.
(Reporter)

Comment 1

16 years ago
This seems to be true only for some web pages.  I tried the listed printers plus
others on the bug report page with no problem. Does this only affect pages with
frames?  Testing further ...
Reporter: Can you give us a page that is crashing ? (put it in the URL field) 
Severity: major → critical
Keywords: crash
(Assignee)

Comment 3

16 years ago
Also, can you put the trap information into the bug?
(Reporter)

Comment 4

16 years ago
Created attachment 50692 [details]
Example page causing problem
(Reporter)

Comment 5

16 years ago
Exception: <some_random_number> at 0
CS:EIP: 5B:2666
(Assignee)

Comment 6

16 years ago
I'm sorry, can you please post the URL rather than the actual HTML?

And the entry from POPUPLOG.OS2.

Thank you very much.
(Reporter)

Comment 7

16 years ago
The URL above is a temporary copy of the page causing the problem.  I'll keep it
around for a while...

09-25-2001  11:07:53  SYS3170  PID 0054  TID 0001  Slot 006a
E:\MOZILLA\MOZILLA.EXE
00000001
00000000
P1=00000000  P2=XXXXXXXX  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=012815b6  EBX=0128c91c  ECX=00000000  EDX=0012d11c
ESI=00000000  EDI=1d6b3430  
DS=0053  DSACC=d0f3  DSLIM=1fffffff  
ES=0053  ESACC=d0f3  ESLIM=1fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00002666  CSACC=d0df  CSLIM=1fffffff
SS:ESP=0053:0012d0a0  SSACC=d0f3  SSLIM=1fffffff
EBP=00000000  FLG=00012212

Comment 8

16 years ago
worksforme on Win98...must be OS/2 issue.. 
(Assignee)

Comment 9

16 years ago
Definitely crashes on OS/2. I'll take it as an OS/2 bug.
Assignee: dcone → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

16 years ago
While this is happening on our 0.9.2.1 build, it is not happening on the trunk 
anymore.

Can you please try with the latest os/2 nightly?
(Reporter)

Comment 11

16 years ago
Seems to be fixed now -- thanks.  (Build id 2001102819)
Sorry it too me so long to test this.
This build seems more stable too, so far no random hang-ups (fingers crossed).

Comment 12

16 years ago
resolving per Peter's comments.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.