Extend the retention period of UITour.seenPageIDs

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Unfocused, Assigned: Unfocused)

Tracking

30 Branch
Firefox 32
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox30+ fixed, firefox31+ fixed, firefox32 fixed)

Details

(Whiteboard: p=3 s=it-32c-31a-30b.3 [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

Currently, UITour.seenPageIDs is retained for 2 weeks. We're debating whether this is currently long enough to be useful (especially given the fallout of having discovered bug 1012526 so late).
We haven't come to a decision whether we need this yet, but a heads up that we possibly may need this in 30. I know it's getting late in the cycle :\ Will be only a really low-risk config change though.
Marco, could you add this to the current iteration? (I need to get couple of possible patches ready in case we decide we need this.)
Flags: needinfo?(mmucci)
Whiteboard: p=3
Posted patch Patch v1 - 4 weeks (obsolete) — Splinter Review
Ok, I figure if do end up needing this, it'll likely end up being one of two options, extending the retention to either:
* 4 weeks (twice existing retention)
* 8 weeks (2 weeks more than one cycle)

This patch makes it 4 weeks.
And this patch makes it 8 weeks.
Added to Iteration 32.2
Flags: needinfo?(mmucci)
Whiteboard: p=3 → p=3 s=it-32c-31a-30b.2 [qa?]
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa?] → p=3 s=it-32c-31a-30b.3 [qa?]
Whiteboard: p=3 s=it-32c-31a-30b.3 [qa?] → p=3 s=it-32c-31a-30b.3 [qa-]
Who is to make the final call here on the duration?  We've got one more desktop Beta to land this to which goes to build on Thursday so this will have to be decided (and whichever patch is to be uplifted nominated) before Thurs am PT or we will not be able to adjust this for FF30.
Flags: needinfo?(bmcbride)
(In reply to Lukas Blakk [:lsblakk] from comment #6)
> Who is to make the final call here on the duration?

That'd be me. I'm still trying to gather more information/opinions from people in awkward timetimes.
Flags: needinfo?(bmcbride)
Flags: firefox-backlog+
Attachment #8428521 - Attachment is obsolete: true
Ok, after talking more with Ilana and Habber, seems the 8 week retention period is our best option.
Comment on attachment 8428522 [details] [diff] [review]
Patch v1 - 8 weeks

Review of attachment 8428522 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8428522 - Flags: review+
Comment on attachment 8428522 [details] [diff] [review]
Patch v1 - 8 weeks

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 952568, bug 1012526
User impact if declined: No user impact. Impact is lack of usable Telemetry data, affecting analysis of impact of whats-new tour page on usage of UI.
Testing completed (on m-c, etc.): Unit tested
Risk to taking this patch (and alternatives if risky): Very minimal - only changing a hardcoded configuration option (and updating associated test).
String or IDL/UUID changes made by this patch: None
Attachment #8428522 - Flags: approval-mozilla-beta?
Attachment #8428522 - Flags: approval-mozilla-aurora?
(Note: Due to the "wonderful" nature of timezones, it's possible I won't be able to land this on Aurora/Beta myself in time, once it gets approval.)
https://hg.mozilla.org/mozilla-central/rev/9c26bf515b44
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Status: RESOLVED → VERIFIED
Attachment #8428522 - Flags: approval-mozilla-beta?
Attachment #8428522 - Flags: approval-mozilla-beta+
Attachment #8428522 - Flags: approval-mozilla-aurora?
Attachment #8428522 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.