Crash in nsWindow.cpp when going to URL

VERIFIED DUPLICATE of bug 103997

Status

()

Core
XUL
P1
critical
VERIFIED DUPLICATE of bug 103997
16 years ago
16 years ago

People

(Reporter: Luke Levesque, Assigned: Eric Vaughan)

Tracking

({crash})

Trunk
mozilla0.9.7
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Upon going to the URL listed, I get a crash.  Shown is the entry in
popuplog.os2:

------------------------------------------------------------

09-24-2001  21:28:41  SYS3175  PID 0520  TID 0001  Slot 006a
F:\WARPZILLA\BIN\MOZILLA.EXE
c0000005
1d5cbbbe
P1=00000001  P2=0000000c  P3=XXXXXXXX  P4=XXXXXXXX
EAX=002c4140  EBX=00fd8db8  ECX=1d5e2368  EDX=ffffffff
ESI=00000000  EDI=00000000
DS=0053  DSACC=f0f3  DSLIM=ffffffff
ES=0053  ESACC=f0f3  ESLIM=ffffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d5cbbbe  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00130b40  SSACC=f0f3  SSLIM=ffffffff
EBP=00130b90  FLG=00012202

WDGTOS2.DLL 0001:0000bbbe

Comment 1

16 years ago
I'm able to recreate this. Something toolkit related.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
For some reason the URL was deleted.  Here it is, since it might be important
for others to duplicate the crash:

http://dailynews.yahoo.com/r/fcweb/Tech%2FComputer_Viruses/Magazine%20Articles/Five%20Steps%20for%20Cyber%20Safety/*http://www.businessweek.com/bwdaily/dnflash/may2000/nf00523f.htm?scriptFramed

Comment 3

16 years ago
Interesting.

This one brings down windows as well. I can put a null check in OS/2 to 
workaround it (although some weird asserts happen) but on windows, things just 
crash.

Marking all.

Crash is in widget/nsWindow.cpp on Windows.
Component: Browser-General → XP Toolkit/Widgets
OS: OS/2 → All

Comment 4

16 years ago
Changing abstract and reassigning
Assignee: mkaply → hyatt
QA Contact: doronr → jrgm
Summary: OS/2 - Crash in WDGTOS2.DLL when going to URL → Crash in nsWindow.cpp when going to URL

Comment 5

16 years ago
Windows widget code. --> rods
Assignee: hyatt → rods

Comment 6

16 years ago
Over to Eric....

Stack trace:

NTDLL! 77f9eea9()
nsWindow::Create(nsWindow * const 0x03a2ab44, nsIWidget * 0x03c09cf4, const 
nsRect & {...}, nsEventStatus (nsGUIEvent *)* 0x03124d90 HandleEvent(nsGUIEvent 
*), nsIDeviceContext * 0x03c2bf40, nsIAppShell * 0x00000000, nsIToolkit * 
0x00000000, nsWidgetInitData * 0x0012ec10) line 1199
nsView::CreateWidget(nsView * const 0x03a2aa78, const nsID & {...}, 
nsWidgetInitData * 0x0012ec10, void * 0x00000000, int 1) line 958
nsScrollPortView::CreateScrollControls(nsScrollPortView * const 0x03a2aad8, void 
* 0x00000000) line 162
nsScrollBoxFrame::CreateScrollingView(nsIPresContext * 0x03a3ea40) line 296
nsScrollBoxFrame::Init(nsScrollBoxFrame * const 0x046b2354, nsIPresContext * 
0x03a3ea40, nsIContent * 0x04832f58, nsIFrame * 0x046b20ec, nsIStyleContext * 
0x047924a0, nsIFrame * 0x00000000) line 102
nsCSSFrameConstructor::InitAndRestoreFrame(nsIPresContext * 0x03a3ea40, 
nsFrameConstructorState & {...}, nsIContent * 0x04832f58, nsIFrame * 0x046b20ec, 
nsIStyleContext * 0x047924a0, nsIFrame * 0x00000000, nsIFrame * 0x046b2354) line 
6437 + 32 bytes
nsCSSFrameConstructor::BeginBuildingScrollFrame(nsIPresShell * 0x03c98748, 
nsIPresContext * 0x03a3ea40, nsFrameConstructorState & {...}, nsIContent * 
0x04832f58, nsIStyleContext * 0x046b2054, nsIFrame * 0x046b1f98, nsIAtom * 
0x0116ba50, nsIDocument * 0x0471fba0, int 1, nsIFrame * & 0x046b20ec, 
nsCOMPtr<nsIStyleContext> & {...}, nsIFrame * & 0x00000000, nsIFrame * 
0x00000000) line 5
nsCSSFrameConstructor::ConstructRootFrame(nsCSSFrameConstructor * const 
0x03c20b80, nsIPresShell * 0x03c98748, nsIPresContext * 0x03a3ea40, nsIContent * 
0x04832f58, nsIFrame * & 0x00000000) line 3632
StyleSetImpl::ConstructRootFrame(StyleSetImpl * const 0x03c12750, nsIPresContext 
* 0x03a3ea40, nsIContent * 0x04832f58, nsIFrame * & 0x00000000) line 1179 + 39 
bytes
PresShell::InitialReflow(PresShell * const 0x03c98748, int 15255, int 8925) line 
2619
HTMLContentSink::StartLayout() line 3877
HTMLContentSink::DidBuildModel(HTMLContentSink * const 0x04730718, int 0) line 
2728
CNavDTD::DidBuildModel(CNavDTD * const 0x039f8d88, unsigned int 2152596471, int 
1, nsIParser * 0x03a28910, nsIContentSink * 0x04730718) line 668 + 14 bytes
nsParser::DidBuildModel(unsigned int 2152596471) line 1422 + 60 bytes
nsParser::Terminate() line 1499
nsHTMLDocument::StopDocumentLoad(nsHTMLDocument * const 0x0471fba0) line 894
DocumentViewerImpl::Stop(DocumentViewerImpl * const 0x03a29da8) line 1247
nsDocShell::Stop(nsDocShell * const 0x046baab0, unsigned int 3) line 2294
nsDocShell::Destroy(nsDocShell * const 0x046baab4) line 2439
nsWebShell::Destroy(nsWebShell * const 0x046baab4) line 1396
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 681
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x0470457c, nsIPresContext * 0x03c7fbf0) line 
453 + 34 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x03c7fbf0) line 116
nsContainerFrame::Destroy(nsContainerFrame * const 0x0470453c, nsIPresContext * 
0x03c7fbf0) line 121
nsFrameList::DestroyFrames(nsIPresContext * 0x03c7fbf0) line 116
nsContainerFrame::Destroy(nsContainerFrame * const 0x047041f8, nsIPresContext * 
0x03c7fbf0) line 121
nsFrameList::DestroyFrames(nsIPresContext * 0x03c7fbf0) line 116
nsContainerFrame::Destroy(nsContainerFrame * const 0x0477a2bc, nsIPresContext * 
0x03c7fbf0) line 121
nsLineBox::DeleteLineList(nsIPresContext * 0x03c7fbf0, nsLineBox * 0x0477a370) 
line 252
nsBlockFrame::Destroy(nsBlockFrame * const 0x04779f38, nsIPresContext * 
0x03c7fbf0) line 311 + 16 bytes
nsFrameList::DestroyFrame(nsIPresContext * 0x03c7fbf0, nsIFrame * 0x04779f38) 
line 202
CanvasFrame::RemoveFrame(CanvasFrame * const 0x04779884, nsIPresContext * 
0x03c7fbf0, nsIPresShell & {...}, nsIAtom * 0x00000000, nsIFrame * 0x04779f38) 
line 356
FrameManager::RemoveFrame(FrameManager * const 0x04739738, nsIPresContext * 
0x03c7fbf0, nsIPresShell & {...}, nsIFrame * 0x04779884, nsIAtom * 0x00000000, 
nsIFrame * 0x04779f38) line 859
nsCSSFrameConstructor::ReconstructDocElementHierarchy(nsCSSFrameConstructor * 
const 0x04676668, nsIPresContext * 0x03c7fbf0) line 7119 + 61 bytes
StyleSetImpl::ReconstructDocElementHierarchy(StyleSetImpl * const 0x03a1ad10, 
nsIPresContext * 0x03c7fbf0) line 1186
PresShell::ReconstructFrames() line 5105 + 41 bytes
PresShell::StyleSheetAdded(PresShell * const 0x03a16cd0, nsIDocument * 
0x04675c70, nsIStyleSheet * 0x046bc6f8) line 5117
nsDocument::InsertStyleSheetAt(nsDocument * const 0x04675c70, nsIStyleSheet * 
0x046bc6f8, int 0, int 1) line 1386
CSSLoaderImpl::InsertSheetInDoc(nsICSSStyleSheet * 0x046bc6f8, int 0, nsIContent 
* 0x04743ee0, int 1, nsICSSLoaderObserver * 0x00000000) line 1121
CSSLoaderImpl::SheetComplete(nsICSSStyleSheet * 0x046bc6f8, SheetLoadData * 
0x047793c0) line 824
CSSLoaderImpl::ParseSheet(nsIUnicharInputStream * 0x0472ebd8, SheetLoadData * 
0x047793c0, int & 1, nsICSSStyleSheet * & 0x046bc6f8) line 879
CSSLoaderImpl::DidLoadStyle(nsIStreamLoader * 0x047795c8, nsString * 0x04735e80, 
SheetLoadData * 0x047793c0, unsigned int 0) line 914 + 27 bytes
SheetLoadData::OnStreamComplete(SheetLoadData * const 0x047793c0, 
nsIStreamLoader * 0x047795c8, nsISupports * 0x00000000, unsigned int 0, unsigned 
int 3356, const char * 0x047c3028) line 671
nsStreamLoader::OnStopRequest(nsStreamLoader * const 0x047795cc, nsIRequest * 
0x046fb338, nsISupports * 0x00000000, unsigned int 0) line 121 + 81 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x046fb340, nsIRequest * 
0x046fb56c, nsISupports * 0x00000000, unsigned int 0) line 465 + 41 bytes
nsOnStopRequestEvent::HandleEvent() line 162
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x046f6524) line 65
PL_HandleEvent(PLEvent * 0x046f6524) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0102ffa0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000f0bee, unsigned int 49396, unsigned int 0, 
long 16973728) line 1071 + 9 bytes
USER32! 77e148dc()
USER32! 77e14aa7()
USER32! 77e266fd()
nsAppShellService::Run(nsAppShellService * const 0x01120ab0) line 442
main1(int 1, char * * 0x00358110, nsISupports * 0x00000000) line 1278 + 32 bytes
main(int 1, char * * 0x00358110) line 1606 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
Assignee: rods → evaughan
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → mozilla0.9.5

Updated

16 years ago
Keywords: crash
(Assignee)

Comment 7

16 years ago
pushing out
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 8

16 years ago
Same stack trace as bug 103997

*** This bug has been marked as a duplicate of 103997 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
I'm on build 20011109 (OS/2) and it goes to this URL now without crashing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.