Closed Bug 1014905 Opened 6 years ago Closed 5 years ago

Endless redirects on t-online.de

Categories

(Web Compatibility :: Mobile, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sfleiter, Unassigned, Mentored)

References

()

Details

(Whiteboard: [clientsniff][country-de][contactready])

Opening http://www.t-online.de/eltern/baby/id_69512620/vornamen-kind-darf-schaklin-heissen.html on Firefox for Android there seem to be endless redirects to http://m.t-online.de/index.html#article?id=69512620.
It loads forever and the content stays empty.

Tested broken from Firefox for Android 29.0.1 to current nightly b40296602082.
This works flawlessly with Chrome for Android.

According to Alexa t-online.de is ranked #13 in Germany:
http://www.alexa.com/siteinfo/t-online.de
They are doing bad user agent detecting. I can reproduce this on desktop with the Firefox for Android user agent.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Hardware: ARM → All
Version: Firefox 29 → Trunk
See Also: → 969833
There is some JavaScript-based sniffing on this page that redirects to the desktop site - the desktop site has backend sniffing that redirects back to the mobile page. The client-side sniffing thinks we're an Android tablet based on this code:

androidVersion:function(){var e=navigator.userAgent,f=e.indexOf("Android");return e.substr(f+8,3)}

,isAndroidTablet:function(){if(!TOMO.Util.System.isAndroid())return!1;var e=TOMO.Util.System.androidVersion();return 3<=e&&4>e?!0:-1==navigator.userAgent.indexOf("Mobile Safari/")}


TOMO_check_os_version=function(){var d=System;if(d.isNativeApp())return!0;if(d.isIphone())return 4>d.iOSVersion()?(TOMO_show_invalid_device_message(),!1):!0;if(/iPad/i.test(navigator.userAgent))return TOMO.classicController.redirectToClassic(),!1;if(d.isAndroid())return 2.2>d.androidVersion()?(TOMO_show_invalid_device_message(),!1):d.isAndroidTablet()?(TOMO.classicController.redirectToClassic(),!1):!0;
Whiteboard: [clientsniff][country-de][contactready][mentor=hsteen]
Mentor: hsteen
Whiteboard: [clientsniff][country-de][contactready][mentor=hsteen] → [clientsniff][country-de][contactready]
This seems to be fixed now.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.