Last Comment Bug 101505 - File input CSS border incorrect
: File input CSS border incorrect
Status: RESOLVED DUPLICATE of bug 52500
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Marc Attinasi
: Chris Petersen
Mentors:
http://www.sayten.34sp.com/mozbugs/10...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-25 03:31 PDT by Matthew Cheale
Modified: 2001-09-25 07:44 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (317 bytes, text/html)
2001-09-25 06:31 PDT, Boris Zbarsky [:bz] (still a bit busy)
no flags Details

Description Matthew Cheale 2001-09-25 03:31:50 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

Applying a CSS border to a file input box doesn't format the file box properly.

Reproducible: Always
Steps to Reproduce:
Create file input box and apply CSS border style.

Actual Results:  The border is around the box but the box keeps it's bevelled
border and then goes over the CSS border.

Expected Results:  Giving the CSS border to the file box and button.
Comment 1 Vidar B. Haarr (old account) 2001-09-25 04:08:39 PDT
confirmed on windows 2000
Mozilla build 20001092403
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2001-09-25 06:30:42 PDT
Happening on Linux too.  Attaching testcase with border color changed to
actually be visible.

At a guess, here is what's happening.  The border is applied to the whole file
control, but also to the text field inside the control (not to the button,
though!).  As a result, the text field is to wide and tall by twice the border
width, with the results that we see.  I'm not sure who this should get assigned
to (layout or form controls); leaving as layout for now.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2001-09-25 06:31:15 PDT
Created attachment 50687 [details]
Testcase
Comment 4 Christopher Aillon (sabbatical, not receiving bugmail) 2001-09-25 07:44:10 PDT

*** This bug has been marked as a duplicate of 52500 ***

Note You need to log in before you can comment on or make changes to this bug.