mozilla -remote doesn't work with 0.9.4 branch

RESOLVED WORKSFORME

Status

()

Core
X-remote
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Martin Macok, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I'm using current (syncing everyday) 0.9.4 branch (I hope it's going to be a new
N6).

0.9.4+ (2001092512), Red Hat Rawhide Linux (current), kernel 2.4.9-ac15, KDE2.2.1.

When I try:
$ cd /opt/mozilla.cvs/mozilla/dist/bin
$ ./mozilla &
(startup output.. running...and then:)
$ ./mozilla-bin -remote "openURL(http://underground.cz/,new-window)" 
No running window found.
$

This WFM with at least 3 days older 0.9.4 pull from CVS.

Comment 1

16 years ago
Also worth testing the recent trunk builds to see if you can reproduce it there...
(Reporter)

Comment 2

16 years ago
WFM with yesterday's trunk snapshot.

Comment 3

16 years ago
why aren't you using ./mozilla -xremote ... ?
Assignee: asa → blizzard
Component: Browser-General → XP Apps: Cmd-line Features
(Reporter)

Comment 4

16 years ago
Because neither ./mozilla -help (branch094) nor
http://www.mozilla.org/unix/remote.html does mention -xremote switch. (and all
of my and other scripts (for example Klipper from KDE 2.2.1) use -remote)

I have tried -xremote "openURL(http://underground.cz/,new-window)" and this does
open new-window but with "about:blank" (doesn't go to specified URL).

Comment 5

16 years ago
erm sorry -remote, my point was to use ./mozila instead of ./mozilla-bin
(Reporter)

Comment 6

16 years ago
I tried both ./mozilla and ./mozilla-bin with same result.Summary:Trunk - everything ok. 0.9.4 milestone - everythinkg ok.Current 0.9.4 BRANCH -a) -remote ... tell's me there no running window of Mozillab) -xremote ... does start new window but doesn't go to specified URL just                about:blank (probably because that's my preferences to new                      window settings)
(Reporter)

Comment 7

16 years ago
(Excuse my last comment formatting - you can blame Konqueror. This time with
mozilla:)

I tried both ./mozilla and ./mozilla-bin with same result.

Summary:
Trunk - everything ok. 
0.9.4 milestone - everythinkg ok.
Current 0.9.4 BRANCH -
 a) -remote ... tell's me there no running window of Mozilla
 b) -xremote ... does start new window but doesn't go to specified URL just
                about:blank (probably because that's my preferences to new     
          
                window setting)

(Assignee)

Comment 8

16 years ago
-xremote shouldn't work at all.  That's not a valid command line switch.  And,
for what it's worth, with my new x remote code in the 0.9.4 branch ( after the
original 0.9.4 mozilla release ) -remote is working just fine.
(Reporter)

Comment 9

16 years ago
This solved it: 

make clean
gmake -f client.mk

I should do "make clean" more often ... sorry.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
Component: XP Apps: Cmd-line Features → X-remote
You need to log in before you can comment on or make changes to this bug.