Closed Bug 1015251 Opened 6 years ago Closed 5 years ago

Create pin dialog does not load when trying to purchase an app on dev with Zippy

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bsilverberg, Assigned: kumar)

References

Details

(Whiteboard: [fromAutomation])

Attachments

(2 files)

Bug #1013397 has morphed into a different bug, so I am opening a new one.

Now, on Firefox OS, when trying to purchase an app on dev with Zippy, after clicking the purchase button the Payment UI frame loads, but then the content of that frame is just a spinner that keeps on spinning, with the word 'Loading...' below it. The title of the frame reads "Marketplace Dev".

This problem comes earlier than the problem reported in bug 1013397, so it looks like it would need to be addressed first.



Two of our tests for payments on Firefox OS are failing after the create/confirm pin step. Our tests are waiting for the "Buy app" screen to display, but instead of that screen we are presented with one with the text "Oops... This is taking longer than expected. Try Again?" and I can see in the background behind this semi-opaque dialog the word "TRANS_TIMEOUT". I will attach a screen cap of this screen.

These have been failing consistently with this error since 12-May-2014 at 12:31:53.

A copy of the html report showing the errors can be found at [1].

Manual STR:

1. Launch Marketplace-dev
2. Login with a valid user
3. Set your region to 'US'
4. Search for the app 'Test Zippy with Me'
5. Click on the app to see the details
6. Click on the price button to purchase the app
7. Enter a pin into the "Create a Pin" dialog
8. Re-enter the pin into the "Confirm Pin" dialog
9. Wait a long time
10. See the screen "Oops... This is taking longer than expected. Try again?"
11. Click "OK"
12. Wait a long time
13. See the screen "Oops... This is taking longer than expected. Try again?"
14. Repeat steps 11 through 13 until you get bored

[1] http://selenium.qa.mtv2.mozilla.com:8080/job/b2g.hamachi.mozilla-b2g28_v1_3.v1.3.marketplace/479/HTML_Report/
Oh lovely, I neglected to remove the description from the bug I cloned. Please ignore everything above except for what's included below:

> 
> Bug #1013397 has morphed into a different bug, so I am opening a new one.
> 
> Now, on Firefox OS, when trying to purchase an app on dev with Zippy, after
> clicking the purchase button the Payment UI frame loads, but then the
> content of that frame is just a spinner that keeps on spinning, with the
> word 'Loading...' below it. The title of the frame reads "Marketplace Dev".
> 
> This problem comes earlier than the problem reported in bug 1013397, so it
> looks like it would need to be addressed first.
>
it's causing the same exact traceback as bug 1013397 which means it's still a Zippy problem and/or a problem with this specific app.

http://sentry.dmz.phx1.mozilla.com/marketplace-dev/marketplace-dev-webpay/group/19738/

ValueError: Unable to find a valid seller_uuid for public_id 808b62a3-b0ac-4fe1-859f-7a7bcffaaf8a

Stacktrace (most recent call last):

  File "celery/task/trace.py", line 228, in trace_task
    R = retval = fun(*args, **kwargs)
  File "celery/task/trace.py", line 415, in __protected_call__
    return self.run(*args, **kwargs)
  File "nuggets/celeryutils.py", line 35, in wrapped
    return fun(*args, **kw)
  File "multidb/pinning.py", line 46, in decorator
    return func(*args, **kw)
  File "multidb/pinning.py", line 46, in decorator
    return func(*args, **kw)
  File "django/db/transaction.py", line 223, in inner
    return func(*args, **kwargs)
  File "webpay/pay/tasks.py", line 231, in start_pay
    provider_names)
  File "webpay/pay/tasks.py", line 188, in get_provider_seller_uuid
    public_id=public_id))
If it's a problem with the app can we get around it by deleting and recreating the app? Krupa, do you want to try that?
Flags: needinfo?(krupa.mozbugs)
So, is the assumption that deleting this app and creating a new one  will fix this issue?
Flags: needinfo?(krupa.mozbugs)
I doubt it. Zippy isn't in production anywhere which means it probably broke inadvertently when we refactored all our code for multiple providers (i.e. Boku). Someone would have to look at Zippy to see what exactly is broken. 

I have voted for running automated tests against Boku because they allow us to simulate transactions and their servers seem stable (unlike Bango). This will be a double win since Boku will theoretically go live soon, unlike Zippy.
I am not very happy depending on third-party provided features to test our side of Payments. Zippy should be our primary way of testing for regressions. This is also a good way to sell our reference implementation to payment providers like Bango. When boku integration is complete, we can add more coverage for their flows. But for now, we should have zippy up and running so we can have more testing of our code.
Depends on: 1048590
I am now seeing a different error when trying to purchase an app via Zippy.  Similar STR:

1. Launch Marketplace-dev
2. Login with a valid user
3. Set your region to 'US'
4. Search for the app 'Test Zippy with Me'
5. Click on the app to see the details
6. Click on the price button to purchase the app
7. Expect to see the "Create a Pin" dialog, but instead see "Oops. An unexpected error occurred. VERIFY_FAILED"

See the attached screenshot.
Andy, I understand that Zippy is meant to be up and running on dev again. Can you please look into this issue when you have time to help unblock the payments tests?
Flags: needinfo?(amckay)
Flags: needinfo?(amckay)
Blocks: 1058529
Assignee: nobody → kumar.mcmillan
bug 1076279 should fix this. As explained in that bug, you'll have to submit new paid apps on dev to test with. Let me know if you still run into trouble.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.