Closed Bug 1015431 Opened 6 years ago Closed 6 years ago

[B2G][Flame][Vertical Homescreen] Flash of open animated app menu is seen on locked device when user wakes it

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1016483
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: rpribble, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [systemsfe], [2.0-flame-test-run-1])

Attachments

(2 files)

Description:
If the user locks the device while an app with animation playing is open and running, then presses the lock button again to wake the device, they will see a flash of the open app before the device moves to the lock screen (app Slice Fruits used in testing).

Repro Steps:
1) Updated Flame to BuildID: 20140523073020
2) Set UI to vertical scroll
3) Download an app from the marketplace with animation on the menu/home screen (Slice Fruits)
4) Lock the device
5) Press the lock button again
6) Observe flash of running app

Actual:
User sees a flash of the running app before being shown the lock screen.

Expected:
Content is not able to be seen if device is locked.

Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2

Notes:

Repro frequency: 100%
See attached: Video

-------------------------------------------------

This issue also occurs on the Open_C v2.0 engineering build.

Open C 2.0 Eng
2.0 Environmental Variables:
Device: Open_C v2.0 MOZ ril
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

User sees a flash of the running app before being shown the lock screen.
Attached file Logcat.txt
Attached audio Video.ogg
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Whiteboard: systemfe → [systemsfe]
No longer blocks: vertical-homescreen
Does this reproduce on the old homescreen?
Keywords: qawanted
This issue DOES repro on the old homescreen.

Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2
Keywords: qawanted
Ok - can we check if this reproduces on 1.4?
Keywords: qawanted
This issue does NOT repro on 1.4

1.4 Environmental Variables:
Device: Flame 1.4
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10G-2
Keywords: qawanted
QA Contact: ekramer
This is not specific to the homescreen, but still something we should absolutely fix. To help the engineers focus on their appropriate areas, I would like to remove blocking on Test plan bugs. Let me know if you have any problems of that.

At the same time I would like to ni? alive here in case he is aware of any recent window manager changes that may have caused this.
No longer blocks: 1015336
Flags: needinfo?(alive)
(In reply to Kevin Grandon :kgrandon from comment #7)
> This is not specific to the homescreen, but still something we should
> absolutely fix. To help the engineers focus on their appropriate areas, I
> would like to remove blocking on Test plan bugs. Let me know if you have any
> problems of that.
> 
> At the same time I would like to ni? alive here in case he is aware of any
> recent window manager changes that may have caused this.

That makes sense to me.
blocking-b2g: --- → 2.0?
I suspect this is due to lockscreenWindow z-index fail.
Greg, are you able to work on?
Flags: needinfo?(alive) → needinfo?(gweng)
In fact this happens after some recent bugs landed (after 5/10 I remembered), and I've solved it once in as-an-app bug. But I think it's good to have a clear regression.

I'll do a bisect after complete the current work.
Flags: needinfo?(gweng)
blocking-b2g: 2.0? → 2.0+
This issue is now occurring with all apps on the newest build, regardless of if they have animated elements or not.

Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v1.2-device.cfg

If user has an app open, then locks the device, then presses the unlock button to view the lock screen, they will see a flash of the app before the lock screen loads correctly.
Whiteboard: [systemsfe] → [systemsfe], [2.0-flame-test-run-1]
I've bisect this is a regression caused by Bug 1009950. I would take a look if we can back it out or the author (Etienne) can fix it in another bug.
No longer depends on: 1009950
Looks like the fix for bug 1016483 also fixed this issue.
I still get a white flash some times when turning the screen on (we've had this since the lockscreen window introduction) but I never see the app.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016483
You need to log in before you can comment on or make changes to this bug.