Closed Bug 1015617 Opened 7 years ago Closed 7 years ago

Intermittent browser_962069_drag_to_overflow_chevron.js | Uncaught exception - Panel did not hide within 20 seconds. | Uncaught exception - Panel did not show within 20 seconds.

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox37 --- fixed
firefox38 --- fixed
firefox39 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected

People

(Reporter: philor, Assigned: enndeakin)

References

Details

(Keywords: intermittent-failure)

Attachments

(4 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=40329492&tree=Mozilla-Inbound
Windows 7 32-bit mozilla-inbound debug test mochitest-browser-chrome-1 on 2014-05-23 22:01:14 PDT for push d6c58a2a6da4
slave: t-w732-ix-025

https://tbpl.mozilla.org/php/getParsedLog.php?id=40328602&tree=Mozilla-Inbound
Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound debug test mochitest-browser-chrome-1 on 2014-05-23 21:49:39 PDT for push d29af2ac48cf
slave: talos-mtnlion-r5-073

22:19:33     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_962069_drag_to_overflow_chevron.js | Overflow panel is shown.
22:19:33     INFO -  --DOCSHELL 32222D20 == 52 [pid = 3464] [id = 1540]
(more GC, since nothing else is happening)
22:19:53  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_962069_drag_to_overflow_chevron.js | Uncaught exception - Panel did not hide within 20 seconds.
Assignee: nobody → jaws
Jared, do you think you'll be able to work on this soonish? If not, I can take a look!
Flags: needinfo?(jaws)
It's all yours :)
Assignee: jaws → mdeboer
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Marco, can you add this to the current iteration?
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Whiteboard: p=3 [qa-]
Added to Iteration 32.3
Flags: needinfo?(mmucci)
Whiteboard: p=3 [qa-] → p=3 s=it-32c-31a-30b.3 [qa-]
Comment on attachment 8434152 [details] [diff] [review]
Patch v1: close the panel directly, instead of relying on keyboard events and window focus

Review of attachment 8434152 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me

::: browser/components/customizableui/test/browser_962069_drag_to_overflow_chevron.js
@@ +23,5 @@
>    let overflowChevron = document.getElementById("nav-bar-overflow-button");
>    ChromeUtils.synthesizeDrop(identityBox, overflowChevron, [], null);
>    yield panelShownPromise;
>  
>    ok(true, "Overflow panel is shown.");

Unrelated, but this should actually test something, like: 

is(widgetOverflowPanel.state, "open", ...)

but that is fragile because the panel might have been hidden again by the time the (async!) .then() of the promise causes this code to continue and the test function to be called...

... or use info() instead. But no ok(true), please. :-)
Attachment #8434152 - Flags: review?(jaws) → review+
Thanks, Gijs! I also adjusted the line you noticed.

https://hg.mozilla.org/integration/fx-team/rev/c9db5a1356bc
Attachment #8434152 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/c9db5a1356bc
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Sooo... looks like we're not done yet. Is it plausible that the panel gets hidden before the listener is added?
IOW, something like this?
Attachment #8434993 - Flags: review?(mdeboer)
Comment on attachment 8434993 [details] [diff] [review]
listen for hiding the panel immediately

Review of attachment 8434993 [details] [diff] [review]:
-----------------------------------------------------------------

Let's try it! Can you add newlines before and after change? Just a nit :)
Attachment #8434993 - Flags: review?(mdeboer) → review+
*the change
Comment on attachment 8434993 [details] [diff] [review]
listen for hiding the panel immediately

remote:   https://hg.mozilla.org/integration/fx-team/rev/707b7bcc4fca
Attachment #8434993 - Flags: checkin+
Keywords: leave-open
(In reply to TBPL Robot from comment #105)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=41171422&tree=Mozilla-
> Central
> Ubuntu VM 12.04 x64 mozilla-central debug test mochitest-browser-chrome-1 on
> 2014-06-05 19:46:55
> revision: c08a299f2163
> slave: tst-linux64-spot-622
> 
> TEST-UNEXPECTED-FAIL |
> chrome://mochitests/content/browser/browser/components/customizableui/test/
> browser_962069_drag_to_overflow_chevron.js | Uncaught exception - Panel did
> not hide within 20 seconds.

Just to save everyone else the detective work I just did, this was just before the last patch hit m-c, and the try push (comment #106) also didn't have it.
Ditto for the try stars. Considering previous rate of failure, I am hopeful that this is it, but let's wait until the end of the weekend.
Sounds like this is FIXED?
Looks like it!
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Keywords: leave-open
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #113)
> Sounds like this is FIXED?

(In reply to :Gijs Kruitbosch from comment #114)
> Looks like it!

I see with my ears, it's confusing.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Added to Iteration 33.1
Whiteboard: p=3 s=it-32c-31a-30b.3 [qa-] → p=3 s=33.1 [qa-]
These new failures look more like something caused by bug 994117.
Status: REOPENED → ASSIGNED
Iteration: --- → 33.2
Points: --- → 3
QA Whiteboard: [qa-]
Whiteboard: p=3 s=33.1 [qa-]
Iteration: 33.2 → 33.3
Iteration: 33.3 → 34.1
Removed from Iteration 34.1 based on review by GMC.
Assignee: mdeboer → nobody
Status: ASSIGNED → NEW
Iteration: 34.1 → ---
Summary: Intermittent browser_962069_drag_to_overflow_chevron.js | Uncaught exception - Panel did not hide within 20 seconds. → Intermittent browser_962069_drag_to_overflow_chevron.js | Uncaught exception - Panel did not hide within 20 seconds. | Uncaught exception - Panel did not show within 20 seconds.