Closed Bug 1015657 Opened 9 years ago Closed 9 years ago

gaia-integration permaorange: TEST-UNEXPECTED-FAIL | undefined | toggle calendar > regular event "before each" hook etc.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

x86
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
2.0 S4 (20june)

People

(Reporter: philor, Assigned: mmedeiros)

References

Details

(Keywords: intermittent-failure)

Caused by something in https://tbpl.mozilla.org/?tree=B2g-Inbound&showall=1&rev=75a0a15111ff

https://tbpl.mozilla.org/php/getParsedLog.php?id=40297512&tree=B2g-Inbound
b2g_ubuntu64_vm b2g-inbound opt test gaia-integration on 2014-05-23 12:35:36 PDT for push 75a0a15111ff
slave: tst-linux64-spot-718

13:20:56     INFO -  TEST-START | toggle calendar > regular event disable calendar month view
13:21:18     INFO -  TEST-UNEXPECTED-FAIL | undefined | toggle calendar > regular event "before each" hook
13:21:19     INFO -  TEST-START | toggle calendar > all day event should not hide all day on day view
13:21:41     INFO -  TEST-UNEXPECTED-FAIL | undefined | toggle calendar > all day event "before each" hook
...
13:31:06     INFO -    1) toggle calendar > regular event "before each" hook:
13:31:06     INFO -    NoSuchElement: (7) Unable to locate element: .pack-checkbox
13:31:06     INFO -    Remote Stack:
13:31:06     INFO -    <none>
13:31:06     INFO -        at Error.MarionetteError (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)
13:31:06     INFO -        at Object.Client._handleCallback (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)
13:31:06     INFO -        at /builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21
13:31:06     INFO -        at TcpSync.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)
13:31:06     INFO -        at Object.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)
13:31:06     INFO -        at Object.Client._sendCommand (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)
13:31:06     INFO -        at Object._findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1303:19)
13:31:06     INFO -        at Object.findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1352:32)
13:31:06     INFO -        at Object.findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/element.js:67:32)
13:31:06     INFO -        at Object.Settings.toggleCalendar (/builds/slave/test/gaia/apps/calendar/test/marionette/lib/views/settings.js:42:8)
13:31:06     INFO -        at toggleLocalCalendar (/builds/slave/test/gaia/apps/calendar/test/marionette/toggle_calendar_test.js:17:18)
13:31:06     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/calendar/test/marionette/toggle_calendar_test.js:38:7)
13:31:06     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:223:21)
13:31:06     INFO -        at Hook.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
13:31:06     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:259:10)
13:31:06     INFO -        at Object._onImmediate (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:276:5)
13:31:06     INFO -        at processImmediate [as _immediateCallback] (timers.js:330:15)
13:31:06     INFO -    2) toggle calendar > all day event "before each" hook:
13:31:06     INFO -    NoSuchElement: (7) Unable to locate element: .pack-checkbox
13:31:06     INFO -    Remote Stack:
13:31:06     INFO -    <none>
13:31:06     INFO -        at Error.MarionetteError (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)
13:31:06     INFO -        at Object.Client._handleCallback (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)
13:31:06     INFO -        at /builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21
13:31:06     INFO -        at TcpSync.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)
13:31:06     INFO -        at Object.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)
13:31:06     INFO -        at Object.Client._sendCommand (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)
13:31:06     INFO -        at Object._findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1303:19)
13:31:06     INFO -        at Object.findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1352:32)
13:31:06     INFO -        at Object.findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/element.js:67:32)
13:31:06     INFO -        at Object.Settings.toggleCalendar (/builds/slave/test/gaia/apps/calendar/test/marionette/lib/views/settings.js:42:8)
13:31:06     INFO -        at toggleLocalCalendar (/builds/slave/test/gaia/apps/calendar/test/marionette/toggle_calendar_test.js:17:18)
13:31:06     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/calendar/test/marionette/toggle_calendar_test.js:107:7)
13:31:06     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:223:21)
13:31:06     INFO -        at Hook.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
13:31:06     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:259:10)
13:31:06     INFO -        at Object._onImmediate (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:276:5)
13:31:06     INFO -        at processImmediate [as _immediateCallback] (timers.js:330:15)
13:31:06     INFO -  make: *** [test-integration-test] Error 2
Dylan, this is one of those gaia-integration failures which is blocking us from switching to gaia-try.  Can you find an owner?
Blocks: 960072
Flags: needinfo?(doliver)
Gareth, can you do some investigation on this one?
Flags: needinfo?(doliver) → needinfo?(gaye)
Dylan, I'm going to rewrite the toggle calendar tests for Bug 1007519 (since it's indirectly blocking one of the visual refresh patches). It should also fix this bug.
Depends on: 1007519
Flags: needinfo?(gaye)
Forgot to mention that the error that you get on the log is different from Bug 1007519 since the tests was disabled on Travis as soon as failure rate went up (probably some race condition) and the error that TBPL is finding is because the new settings drawer (Bug 940512) changed the DOM structure. So they are 2 different bugs but to get the tests to pass on master I'll end up fixing both.
Component: General → Gaia::Calendar
See Also: → 940512
Thanks Miller!
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.0 S3 (6june)
(note that if it was fixed and Gi showed up on TBPL, we would have backed out today's failure faster :) )
this should be fixed, landed updated toggle calendar tests into master: https://github.com/mozilla-b2g/gaia/commit/67b305497f3ac853c2434bde5969c4a629fca98b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
You need to log in before you can comment on or make changes to this bug.