Closed Bug 1016274 Opened 6 years ago Closed 5 years ago

[Settings][Keyboard][V2.0] Tapping the "<" icon of 3rd party keyboard settings force closes settings app

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+)

RESOLVED DUPLICATE of bug 1016280
blocking-b2g 2.0+

People

(Reporter: whsu, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [FT:System-Platform], [3rd-party-keyboard])

Attachments

(2 files)

Attached video WP_20140527_007.mp4
* Description:
  This is a regression bug.
  After tapping the "<" icon of keyboard settings, FxOS will return to homescreen.
  Attach the demo video.(WP_20140527_007.mp4)

* Reproduction steps:
  1. Install a third party keyboard
  2. Launch the settings app then tap "Keyboards"
  3. Select a settings of installed third party keyboard
  4. Tap "<" to go to previous page

* Expected result:
  Returning to main page of settings app

* Actual result:
  The settings app is unexpectedly closed

* Reproduction build: V2.0 (Buri)
 - Gaia      f3b5d74dd3428c89cab06db734c62f3c9dbb8c4d
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/e86a0d92d174
 - BuildID   20140525160203
 - Version   32.0a1
Whiteboard: [FT:System-Platform], [3rd-party-keyboard]
blocking-b2g: --- → 2.0?
Keywords: regression
QA Wanted to confirm this doesn't reproduce on 1.4.
Keywords: qawanted
Issue does NOT reproduce on 1.4

Environmental Variables:
Device: Flame 1.4
BuildID: 20140528063006
Gaia: 9d632fd4f8965e15a3204f1609136f1b3b3f8bb3
Gecko: 59f7a4964a77
Version: 30.0
Firmware Version: v10G-2


Environmental Variables:
Device: Open_C 1.4
BuildID: 20140528063006
Gaia: 9d632fd4f8965e15a3204f1609136f1b3b3f8bb3
Gecko: 59f7a4964a77
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
Keywords: qawanted
QA Contact: jmitchell
blocking-b2g: 2.0? → 2.0+
Central Hamachi Regression Window:

Last Working:
Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140512044209
Gaia: e8a1eedb848382323254edbd234baecebc5dc5ca
Gecko: 3bb70c0d6845
Version: 32.0a1
Firmware Version: v1.2-device.cfg

First Broken:
Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140512130702
Gaia: 2f89c43e798ccba631025bedc47a1fb24e830cf2
Gecko: b1c9fcb5450b
Version: 32.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e8a1eedb848382323254edbd234baecebc5dc5ca
Gecko: b1c9fcb5450b

First Broken Gaia Last Working Gecko: Issue DOES reproduce (Indicating a GAIA issue)
Gaia: 2f89c43e798ccba631025bedc47a1fb24e830cf2
Gecko: 3bb70c0d6845

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e8a1eedb848382323254edbd234baecebc5dc5ca...2f89c43e798ccba631025bedc47a1fb24e830cf2

<Proceeded to B2G-Inbound>

B2G Inbound Regression Window:

Last Working:
Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140512074006
Gaia: 89fd95d1c0599e6f6c419bc2b243f5b26b8778fe
Gecko: f8ba182364b1
Version: 32.0a1
Firmware Version: v1.2-device.cfg

First Broken:
Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140512075206
Gaia: 2e8f91f13a17f4d8b5c2851f20e5bd5ac67ba304
Gecko: d6c764bec388
Version: 32.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 89fd95d1c0599e6f6c419bc2b243f5b26b8778fe
Gecko: d6c764bec388

First Broken Gaia Last Working Gecko: Issue DOES reproduce <indicating a GAIA issue>
Gaia: 2e8f91f13a17f4d8b5c2851f20e5bd5ac67ba304
Gecko: f8ba182364b1


Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/89fd95d1c0599e6f6c419bc2b243f5b26b8778fe...2e8f91f13a17f4d8b5c2851f20e5bd5ac67ba304
Broken by bug 1007574.

Alive - Any thoughts on this bug?
Blocks: 1007574
Component: Gaia::Settings → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Arthur and Rudy:
I fixed the internal keyboard but we cannot control all the keyboard in the world.
I think it's invalid to kill the settings when no region is specified, how do you think?
Component: Gaia::System::Window Mgmt → Gaia::Settings
Flags: needinfo?(rlu)
Flags: needinfo?(arthur.chen)
Flags: needinfo?(alive)
Assignee: nobody → alive
There is a similar issue bug 1016280 and we're going to have a proper fix as follows,
 1. From keyboard app, invoke settings activity with "window disposition" and without section parameter.
    -> This is currently a hack for keyboard app to go back to settings app.
   
    1.a The above activity name might be changed after settings inline activity work is done, bug 1007600.


 2. For settings app, we should be do postError() in the case when section parameter is undefined.

--
Arthur, please help correct me if I take anything wrong.
Thanks.
Flags: needinfo?(rlu)
I think we should handle these 2 issues with one shot, so dupe this one to bug 1016280.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016280
Comment on attachment 8431289 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/19800

As Rudy suggested, I were trying to solve the issue along with bug 1007600, in which the configure activitiy will be launched in inline disposition. To support the use case of launching settings app in window disposition, we add a new activity called configure_window. The activity allows other apps be able to launch settings app. We did it not only for workaround the problem but also believe such use case does exist.
Attachment #8431289 - Flags: review?(arthur.chen)
Flags: needinfo?(arthur.chen)
Assignee: alive → nobody
(In reply to Arthur Chen [:arthurcc] from comment #9)
> Comment on attachment 8431289 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/19800
> 
> As Rudy suggested, I were trying to solve the issue along with bug 1007600,
> in which the configure activitiy will be launched in inline disposition. To
> support the use case of launching settings app in window disposition, we add
> a new activity called configure_window. The activity allows other apps be
> able to launch settings app. We did it not only for workaround the problem
> but also believe such use case does exist.

I am still against this. Please write a mail to dev-webapi for your request.
It seems we can't make it in v2.0. Let's wait for bug 1005827 before landing bug 1007600.
You need to log in before you can comment on or make changes to this bug.