checksetup.pl fails, and can't finish install

RESOLVED DUPLICATE of bug 100259

Status

()

--
critical
RESOLVED DUPLICATE of bug 100259
18 years ago
6 years ago

People

(Reporter: tclarke, Assigned: zach)

Tracking

2.10
x86
Windows 2000

Details

(URL)

(Reporter)

Description

18 years ago
Have followed install instructions until reaching section regarding running the 
checksetup.pl file. When trying to run this perl script i get the following 
error.
Checking user setup ...
Checking for    MySQL Server (v3.22.5) ok: found v3.23.42-max-nt

DBD::Sponge::db prepare failed: Cannot determine NUM_OF_FIELDS at C:/Perl/site/l
ib/DBD/mysql.pm line 248.
SV = NULL(0x0) at 0x22f0d8c
  REFCNT = 1
  FLAGS = (PADBUSY,PADMY)
Use of uninitialized value in subroutine entry at C:/Perl/site/lib/DBD/mysql.pm
        line 250 (#1)
    (W uninitialized) An undefined value was used as if it were already
    defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
    To suppress this warning assign a defined value to your variables.

    To help you figure out what was undefined, perl tells you what operation
    you used the undefined value in.  Note, however, that perl optimizes your
    program and the operation displayed in the warning may not necessarily
    appear literally in your program.  For example, "that $foo" is
    usually optimized into "that " . $foo, and the warning will refer to
    the concatenation (.) operator, even though there is no . in your
    program.

Uncaught exception from user code:
        Invalid DBI handle  at C:/Perl/site/lib/DBD/mysql.pm line 250.
        DBD::mysql::db::table_info('DBI::db=HASH(0x1de8ad8)') called at C:/Perl/
site/lib/DBI.pm line 1016
        DBD::_::db::tables('DBI::db=HASH(0x1de8ad8)') called at checksetup.pl li
ne 1136

Any advice??? I've tried updating the active perl mysql libraries with no 
effect.
Thanks

Todd.
This is a bug in ActiveState's PPM distribution, not Bugzilla.  See the bug I'm
marking this as a dupe of for details.

*** This bug has been marked as a duplicate of 100259 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.