If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

quicklaunch wont reopen browser on double click , or mail.

VERIFIED WORKSFORME

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Damien Covey, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4+)
Gecko/20010924
BuildID:    2001092403

After closing mozilla (quicklaunch enabled) if I double click on the mozilla
icon in the taskbar, it opens a window in the top left corner that displays only
the title bar.  This window is completely useless, to get a window that I can
browse in i need to left click in the taskbar and select 'Navigator'.  If I want
a mail window from the taskbar, this is seemingly inpossible.  It will do it
once, but not a second time.

Reproducible: Always
Steps to Reproduce:
1.Open Mozilla with quicklaunch enabled.
2.Close Mozilla.
3.Double click Mozilla icon in taskbar.

Actual Results:  Small window in top left corner of screen with titlebar only.

Expected Results:  New browser window.

Comment 1

16 years ago
->quicklaunch
Assignee: asa → law
Component: Browser-General → QuickLaunch (AKA turbo mode)
QA Contact: doronr → gbush
(Assignee)

Comment 2

16 years ago
I can't reproduce this behavior.

Some questions:

1. Do you have multiple profiles?
2. Can you resize the "small window" at all?  By double-clicking the title bar?
3. Is there a title in that title bar?
4. Can you modify your registry so that under
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run, the value
"Mozilla Quick Launch" has the "-console" option as well as "-turbo"?  If you
make that change, is there any useful info in the console window when the small
window is opened?

Thanks.
(Reporter)

Comment 3

16 years ago
Created attachment 51001 [details]
Screen shot of resized titlebar.
(Reporter)

Comment 4

16 years ago
Created attachment 51002 [details]
Window with title bar only.
(Reporter)

Comment 5

16 years ago
Bill,

1. I have muliple windows profiles, one mozilla profile.
2. I can resize the small windows, by either means. See screenshots.
3. No title bar.  Just mozilla icon top left.
4. Editing registry does not help.

More info.  This is a list of all the steps it takes to reproduce on my machine.
 Which is by the way windowsXP if that helps.  Moz build 2001092503.
1. Open moz with quicklaunch enabled.
2. Open mail by clicking mail icon in the bottom left launch area.
3. Close mail.
4. Close moz browser.
5. Open moz browser by double clicking quicklaunch icon.
6. Click mail icon at the bottom left launch area. (Doesn't open up)
7. Close moz browser.
8. Double click quicklaunch icon to open moz. (One small windows with titlebar
only apears).

Of these above steps, the cruitial step to get the small windows is step 6. 
Mail never opens, but it seems to be mail that is the titlebar-only window. 
Without this step, the titlebar-only windows does not apear.

I presume that if mail lauched correctly this other problem would go away.

Hope this helps in some way.

(Reporter)

Comment 6

16 years ago
I've also submitted bugs that probably relate to this one.
http://bugzilla.mozilla.org/show_bug.cgi?id=101649 and
http://bugzilla.mozilla.org/show_bug.cgi?id=101650
The first one is probably more closely related to this bug.

Damien

Comment 7

16 years ago
This bug is similiar to bug 93609.
(Reporter)

Comment 8

16 years ago
Seems to be working fine with the latest nightly.  I un-installed previous
version and then did a fresh install of the nightly and all is well (kept old
profile).  It remains that this probably shouldn't have happened in the first
place and may happen again to someone else.  But it's good for me.
(Assignee)

Comment 9

16 years ago
Resolving WFM per reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
verified
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.