Doorhangers overflow from the window if they are placed on the left and if there is enough space

RESOLVED DUPLICATE of bug 974389

Status

()

--
trivial
RESOLVED DUPLICATE of bug 974389
5 years ago
5 years ago

People

(Reporter: jaramat, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8429909 [details]
screenshot.png

See the attached screenshot.

If there's enough space on the left, the new Australis doorhangers overflow out of the window.

Steps to reproduce:
1. Open Customizing mode
2. Move some buttons with dropdown doorhangers (*) to the left of any toolbar (Menu Bar/Tabs Toolbar/Navigation Bar/Bookmarks Bar/Add-on Bar (if restored))
3. Close the Customizing mode
4. Move the entire non-maximized window slightly to the right, so there's enough space between the left screen border and the outer left window border
5. Click the buttons.

Expected results:
Doorhanger detects it's too close to the inner left window border and opens to the right (like #12 does).

Actual results:
Doorhanger opens to the left, even if there's enough space on the right (screenshot #1-8, see #5).


(*) Affected buttons: Developer (#1), History (#2), Feeds (#3), Downloads (#4), Sidebars (#5), Character Encoding (#6), Edit Bookmark (#8) & Bookmarks Menu (#7).

#9 is fine, because there isn't enough space on the right. Also see #10, #11, #12, and #13 - these are always contained within the window, so they are fine.

Reproducible: With the mentioned buttons, always.

Tested on the latest Nightly (32.0a1 (2014-05-27)) and latest Stable (29.0.1) on Windows 7 Pro x64 SP1.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974389
You need to log in before you can comment on or make changes to this bug.