[open C] support gecko/gaia build for open C

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: viralwang, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
open C should not use flame code base since flame is reference phone to us and we will provide nightly build for flame.
we have no source code for open C and we should use the code on CAF to build gecko/gaia only.
One quick hack to do this is to use the first version flame code. It can build gecko/gaia for bsp qualcomm 8x10.
Reporter

Comment 1

5 years ago
with this attachment we can build gecko/gaia for msm8x10 bsp.
It means we can build gecko for open C in following step:
(I do know the command looks weird but it works)

./config.sh flame openc.xml
./build.sh gecko
./flash.sh gecko
Reporter

Comment 2

5 years ago
Thanks for the feedback from Kobalt :)

When we move gecko to master branch, we should move gaia to master at same time.
If we only do as comment 1 may not work fine, we should also update gaia.

Here's my steps to make a clean build and I'm sure it works in my open C
$ rm -rf objdir-gecko/ out/ backup-flame/
$ ./config.sh flame openc.xml
$ ./build.sh gecko
$ ./flash.sh gecko
$ cd gaia
$ make reset-gaia
Reporter

Comment 3

5 years ago
It looks like we need new fonts for latest gecko/gaia.

https://bugzilla.mozilla.org/show_bug.cgi?id=1032874#c5
There's a package link.
Just need to download it and do "./flash.sh" after connect your device with adb
Any particular reason this manifest hasn't landed yet?

Comment 5

5 years ago
I for one would love to have an official Open C line. It would make troubleshooting a much simpler process.

Comment 6

5 years ago
Chris, is there anything more to do before this goes live?
Flags: needinfo?(cjones.bugs)
Reporter

Comment 7

5 years ago
We didn't actually get any release from partner for open C.
We can only use the code for msm8610 on CAF to build gecko/gaia.
That's why we won't have a formal build for open C.
Is there anything that could be done about that?  Should we all try and contact ZTE on that matter to show our excitement and try and somehow get them to deliver the code?
Sorry, I don't know what the Open C is.  Maybe you meant to ask a different Chris?
Flags: needinfo?(cjones.bugs)

Comment 10

5 years ago
^ I figured you were managing the manifests - my apologies.

I'll look around and try to find a way in for this. Will probably start with contacting partner support.

Duplicate of bug 980658.
since this weekend, use my own compilation of 2.2 brick my phone.

With adb logcat, I had messages :

E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  393): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
Same problem here: I compiled successfully on 22nd December but on the 26th and 29th my phone got bricked.

Comment 13

5 years ago
(In reply to Jean-Baptiste Hétier from comment #12)
> Same problem here: I compiled successfully on 22nd December but on the 26th
> and 29th my phone got bricked.

Hello,
Have you finally managed to compile the last version without bricking your phone ?
Thx
(In reply to Milarepa from comment #13)
> (In reply to Jean-Baptiste Hétier from comment #12)
> > Same problem here: I compiled successfully on 22nd December but on the 26th
> > and 29th my phone got bricked.
> 
> Hello,
> Have you finally managed to compile the last version without bricking your
> phone ?
> Thx

The latest version of FirefoxOS still does not start on open C.

Comment 15

5 years ago
(In reply to Garcia M. (alias TuxGasy) from comment #14)
> (In reply to Milarepa from comment #13)
> > (In reply to Jean-Baptiste Hétier from comment #12)
> > > Same problem here: I compiled successfully on 22nd December but on the 26th
> > > and 29th my phone got bricked.
> > 
> > Hello,
> > Have you finally managed to compile the last version without bricking your
> > phone ?
> > Thx
> 
> The latest version of FirefoxOS still does not start on open C.

Thx for the info.
Were you able to unbrick your phone then ? Have you filled a bug ?
(In reply to Milarepa from comment #15)
> (In reply to Garcia M. (alias TuxGasy) from comment #14)
> > (In reply to Milarepa from comment #13)
> > > (In reply to Jean-Baptiste Hétier from comment #12)
> > > > Same problem here: I compiled successfully on 22nd December but on the 26th
> > > > and 29th my phone got bricked.
> > > 
> > > Hello,
> > > Have you finally managed to compile the last version without bricking your
> > > phone ?
> > > Thx
> > 
> > The latest version of FirefoxOS still does not start on open C.
> 
> Thx for the info.
> Were you able to unbrick your phone then ? Have you filled a bug ?

Yes, I can unbrick my phone to flash ffox v2.1. But I don't have open a new bug.

Comment 17

5 years ago
Garcia and Jean-Baptiste, is this still a problem? If so, could either of you file a bug report? It might become very hard to address it later on.
Flags: needinfo?(me)
Flags: needinfo?(garcia.michel)
The master branch builds and runs properly now.  I think this was the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1058305
Flags: needinfo?(me)

Updated

5 years ago
Flags: needinfo?(garcia.michel) → needinfo?

Comment 19

5 years ago
Awesome. Thanks.
Flags: needinfo?
I confirm. It's ok now. Thanks.

Comment 21

4 years ago
For info, french community made update build for ZTE Open C FR and EU : http://builds.firefoxos.mozfr.org

Comment 22

4 years ago
Unfortunately the french builds for the ZTE Open C EU are not working correctly. Everything seems to work fine but it does not recognize the SIM card and therefore it's not possible to make phone calls, at least on my device.

But back to topic: It would be really helpful if "./config.sh openc" would work, even when building a complete image isn't possible yet. Furthermore this would make commands like "BRANCH=v2.1 ./config.sh openc" working OOTB -- currently these do not work since the branch request will be overwritten by the openc.xml file, so without patching the XML file additionally it's always the master branch which will be build. (BTW: It would be very helpful to have this infomation on the "ZTC Open C" side on MDN.)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.