Closed Bug 1017018 Opened 8 years ago Closed 8 years ago

[Messages] Bug 963018 regresses the localizability of the "To:" string in the recipient panel

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: julienw, Assigned: azasypkin)

References

Details

(Keywords: regression, Whiteboard: [p=1][not-part-of-initial-sprint])

Attachments

(1 file)

After Bug 963018 lands, the recipients panel no longer resizes on the left side if the "To:" string is bigger. This needs to be fixed.
Blocks: 963018
triage: 2.0+ as it's regression
blocking-b2g: 2.0? → 2.0+
Assignee: nobody → azasypkin
Blocks: sms-sprint-2
Status: NEW → ASSIGNED
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [p=1][not-part-of-initial-sprint]
Target Milestone: --- → 2.0 S3 (6june)
Hey Steve,

Could you please review this CSS-only patch? 

The reason why "To" field became non-localizable was its fixed width. Since we use flexbox as the container, we can allow "To" field to grow as much as needed for its content + use "flex-shrink: 0" so that main flexible block will not shrink "To" field while growing.
Attachment #8432937 - Flags: review?(schung)
Also there is one more regression happened to the To input field itself: when user enters very long number that exceeds length of the input itself we no longer shift cursor to the beginning of the input field, but leave it at the end of the input all the time.

We've discussed that with Omega and Jenny offline and decided that current behaviour is actually better, so it's more like unexpected enhancement rather then regression :)
Comment on attachment 8432937 [details] [review]
GitHub pull request URL

Thanks for the fixing! Let's wait for travis
Attachment #8432937 - Flags: review?(schung) → review+
(In reply to Steve Chung [:steveck] from comment #4)
> Comment on attachment 8432937 [details] [review]
> GitHub pull request URL
> 
> Thanks for the fixing! Let's wait for travis

Thanks for review! Travis is green now :)
Keywords: checkin-needed
in master: e94fa5edd20bae6d52787e8ac102625b856e68ee
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.