Wrong tabs are restored via the undo ability after closing multiple tabs at once; the last tab closed is used as the undo for all closed tabs

VERIFIED FIXED in Firefox 32

Status

()

Firefox for Android
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

({reproducible})

Trunk
Firefox 32
ARM
Android
reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 verified, fennec32+)

Details

(Reporter)

Description

4 years ago
Steps to Reproduce

  * In a new tab, open http://polygon.com
  * In a new tab, open http://nvidia.com
  * In a new tab, open http://techmeme.com
  * In the tabs tray, swipe off Polygon, Nvidia, Techmeme

* 'Closed Polygon | Tap Undo' → Opens Techmeme
* 'Closed Nvidia | Tap Undo' → Opens Techmeme
* 'Closed Techmeme | Tap Undo' → Opens Techmeme


--
Nightly (05/28)
Asus Nexus 7 (2013, Android 4.4.2)
(Assignee)

Comment 1

4 years ago
Bug 1015421 would be the way to fix this. We only store one closed tab in session history, so we only have the ability to undo closing the last tab that was closed.
Assignee: nobody → margaret.leibovic
Depends on: 1015421
tracking-fennec: ? → 32+
(Assignee)

Comment 2

4 years ago
I want to see what wesj comes up with in bug 1015421, since that should fix this problem, but to make this more robust we could also pass around tab ids.
(Assignee)

Comment 3

4 years ago
I just tested, and indeed this was fixed by bug 1015421.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Keywords: verifyme

Comment 4

4 years ago
Doesn't matter how many tabs I close and how many times I tap on undo button only the last closed tab is restored.
Is this the correct behavior?

Updated

4 years ago
Flags: needinfo?(margaret.leibovic)
status-firefox32: affected → fixed
Target Milestone: --- → Firefox 32
(Reporter)

Comment 5

4 years ago
(In reply to Flaviu Cos, QA [:flaviu] from comment #4)
> Doesn't matter how many tabs I close and how many times I tap on undo button
> only the last closed tab is restored.
> Is this the correct behavior?

Was this today's build, Nightly (06/04)?

Comment 6

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #5)
> Was this today's build, Nightly (06/04)?
Yes, the 2014-06-04 nightly build.
(Reporter)

Comment 7

4 years ago
This works for me as attempting the steps again as originally filed. The last tab closed is the one that re-opened. The recent toast work replaces the previous visible toast right away so if you swipe away tabs in a row, the toast and the tab it opens will match the one that is closed.
Status: RESOLVED → VERIFIED
status-firefox32: fixed → verified
Flags: needinfo?(margaret.leibovic)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.