Closed Bug 1017137 Opened 7 years ago Closed 1 year ago

Firefox can't print long lists properly from http://chem.sis.nlm.nih.gov/chemidplus/

Categories

(Core :: Printing: Output, defect, P3)

x86
All
defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: mconley, Assigned: mats)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Whiteboard: [layout:print-triage:p1][frag2020_v73])

Attachments

(3 files)

STR:

1) Navigate to: http://chem.sis.nlm.nih.gov/chemidplus/
2) In the automatically focused field, type METHYL
3) In the dropdown above and to the right of that field, select "CONTAINS"
4) In the dropdown to the right of the "Help" button, select 25 to show 25 results per page.
5) Click "Search"
6) The resulting page lists a number of chemicals. In Firefox, attempt to print the page.

Expected Behavior:

Firefox should print what it is showing - the entire list of 25 chemicals. Approximately 6 pages.

Actual Behavior:

Firefox will print only the header, some of the first few chemicals, and then the footer. 3 pages only.
Component: Untriaged → Printing: Output
Product: Firefox → Core
Here's an unminimized testcase, from performing the STR, doing the "save as complete", and getting rid of all the external files except for one stylesheet that's necessary to reproduce the bug, which I've pasted inline in a <style> element.
Priority: -- → P3
Whiteboard: [layout:print-triage:p1]
Attached file Testcase #2

Testcase 1 triggers two separate bugs, the first one is that the main container on the page has display:inline-block, which is a dupe of bug 534182. If you remove that style there's a second bug in table fragmentation that this minimized testcase hits when run with -layoutdebug -paged.

Assignee: nobody → mats
Depends on: 534182
Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/085539912afa
Don't report Complete status in table-row-group fragmentation if it still has more rows to flow after filling the availble size.  r=TYLin
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Blocks: 1601429
Whiteboard: [layout:print-triage:p1] → [layout:print-triage:p1][frag_v73]
Whiteboard: [layout:print-triage:p1][frag_v73] → [layout:print-triage:p1][frag2020_v73]
You need to log in before you can comment on or make changes to this bug.