Closed Bug 1017187 Opened 5 years ago Closed 5 years ago

browser_yahoo_behavior.js leaks until shutdown when running components/search directory by itself

Categories

(Firefox :: Search, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1041537

People

(Reporter: jmaher, Unassigned)

References

Details

while working on bug 992911, we find that many tests leak or timeout when we don't normally see them.  This is because we run each subdirectory by itself to isolate tests from interfering with each other.

In this case the browser/components/search/test subdirectory has a problem on osx [10.6|10.8] debug with browser_yahoo_behavior.js:
https://tbpl.mozilla.org/php/getParsedLog.php?id=38967810&tree=Try

This is a newer test, maybe the fix is easier as it is fresher in our minds.
This is still failing intermittently in a recent try push: https://tbpl.mozilla.org/?tree=Try&rev=6b4c03ec588c , for bc1 jobs on linux, osx and windows.

The goal is to turn these on as --run-by-dir, we don't have too many tests that are problematic(19 total), if we can fix the easy ones now that will help! :)

Mike, can you figure out why it is failing when we run the tests only in browser/components/search/test directory?
Flags: needinfo?(mconnor)
I'm guessing because it's the last one in the sequence.  If you remove it, I'd bet that the previous *_behavior instance fails.  Does it fail if you run it by itself (I don't have a debug build)
Flags: needinfo?(mconnor)
We skipped this test in the manifest for debug and had 20+ other try pushes that when it was skipped didn't show any problems with this test, nor ones before it.  I have one case of browser_eBay_behavior.js failing on osx 10.6 opt out of at least 100 data points.

In many cases it does work out that the last test case is the scapegoat for a shutdown issue.  In this case it could still be somewhat related, but it would have to be more subtle.  As for the data I have now, there is little evidence that it is related to the last test.

In fact here is a try push with this disabled for debug and showing an issue on 10.6 opt for a single failure:
https://tbpl.mozilla.org/?tree=Try&rev=24bb371d0c09 (I view this as intermittent, not something to fix)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041537
You need to log in before you can comment on or make changes to this bug.