Closed Bug 1017536 Opened 6 years ago Closed 6 years ago

WindowManager gets broken after a while

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: gerard-majax, Assigned: alive)

References

Details

Attachments

(1 file)

Reproducing this easily with current master on Nexus S at least.
Logcat shows this everytime I long press the home button:
> E/GeckoConsole(   77): [JavaScript Error: "TypeError: top.browser is null" {file: "app://system.gaiamobile.org/js/app_window.js" line: 1717}]
> E/GeckoConsole(   77): Content JS WARN at app://system.gaiamobile.org/js/app_window_manager.js:102 in awm_display: the app has been displayed.

STR for now:
 0. Boot device
 1. Launch a couple of apps
 2. Launch HERE Maps, let it run for a while

Please note I have been reproducing this since at least a week, maybe more. I can trigger it with other apps, too.

I suspect it may be because of OOM or something like this at some point. It's quite bothering, since you cannot anymore:
 - switch between apps (either task switcher or edge gestures)
 - if you lock the device with one app started, you cannot unlock until you tap twice on the home button

I'll try to reproduce this on Flame also, but I think I did at some point.
I could reproduce on Flame configured with 1GB after opening a lot of apps and switching between those.
Configuring Flame with 256MB the reproductibility is quite fast.
I see the STR here, but I don't understand what the expected/actual results are. Can you clarify?

What's needed for QA testing here also? Looks like you can reproduce on Flame, so we know this is present on a production device.
Keywords: qawanted
There are STRs and expected/actual in comment 1. I should have made it obvious that:

 Expected:
  Window Manager works, we can use edge gestures and tasks switcher

 Actual:
  Unable to switch between apps either with task switcher or edges gestures. This also messes up with locking the device: one need to tap on the home button several times before being able to unlock the device.
Okay - can we confirm this works as expected on 1.4?
Keywords: qawanted
Assignee: nobody → alive
Well, I don't have a flame. Could you test with this?
Attachment #8431305 - Flags: feedback?(lissyx+mozillians)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> Created attachment 8431305 [details]
> https://github.com/mozilla-b2g/gaia/pull/19803/files
> 
> Well, I don't have a flame. Could you test with this?

Alive, Flame isn't needed, I'm reproducing this on nearly all my devices. It seems to be linked with amount of RAM and use in time.
Comment on attachment 8431305 [details]
https://github.com/mozilla-b2g/gaia/pull/19803/files

That seems to be helping!
Attachment #8431305 - Flags: feedback?(lissyx+mozillians) → feedback+
Triage: block based on user impact and low risk of the patch.
blocking-b2g: 2.0? → 2.0+
Attachment #8431305 - Flags: review?(timdream)
Attachment #8431305 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/pull/19803
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Keywords: qawanted
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.